Updating a Raptor Dual Drive

I have two Raptor Dual Drive boards. My remotes both died, so I purchased two nano-xs to replace them. When they arrived I swapped the hardware, but now only one motor will spin on each board. Also, one of the board motors is not so much spinning but sputtering as it very slowly spins… No other changes to firmware or wiring configuration. Any suggestions on how to get back to Dual Drive?

have you tried re doing the vesc setting on it

I am having some issues finding documentation on the hardware and software settings I should be using for the raptor dual drive model. my google-fo isn’t revealing everything I need to know yet, it would seem.


SO I think the 2 still used focboxes

So you have to download the app connect a usb from your computer to the vesc and from there you can redo the setting based on your battery and motors

They are vesc 4.10. I have been able to connect them and run the “setup Motors Foc” and “Setup Input” wizards, but things are still not working properly.

Specifically, there is a red light that flashes on the non running motor/vesc when input is given, while the other motor runs, or sluggishly runs.

So an update. I was able to get both boards to have a single motor controlled by the remote smoothly, successfully. Now both boards have their second, slave vescs, which only sometimes demonstrate that they can power the motor. Both show DRV issues, but also still occasionally show activity. When input is given to the board via the remote, one vesc powers the motor, the other blinks red 3 times.

First off fuck that remote. Idk why they still get away with selling it. It’s hot garbage.

Second, jump on fourms.
That’s where everyone is these days that can really help you work this out.

1 Like

If it is drv then depending where you are multiple people on the forum fix them or there are ways to fix them yourself

thanks for the suggestion, and yeah, the reality of dealing with enertion kicked back in with this experience. It has been a while since i had to deal with their “customer service” and the remotes were technically free because I had credit from when they screwed up hard last time, so not much skin off my nose there. But c’est la vie.

1 Like