Vesc 4.12 FOC - Unwanted torque

Helloo, I’ve been using the vesc with ackmaniac 2.54 with BLDC for some time with no problems and really nice behavior in every way. I have a 9s battery with Nyko Kama Nunchuck controller. Now I have configured ackmaniac 3.1 with FOC and it works all good with nice startup behavior and so on. The only problem is that when applying full torque for a couple of seconds and than releasing it, the board keeps on accelerating for a brief moment, even if going from full throttle to full brake, the board keeps accelerating for a brief moment. No need to say that its really scary and unpredictable.

My best guess is that there is something going on with an integral windup in some controller loop as full throttle is applied. If someone could pinpoint me to what settings to play with I would be grateful!

Can you see the delay in the PPM tab?

This is for nunchuck, I don’t use ppm (edit. Changed around with the positive ramping time but no difference)

I mean when you see the percentage of the Nunchuck throttle, if it’s delayed as well when letting go of throttle.

1 Like

Okej, no, there’s no delay when looking at the bar. When using bldc, the throttle behaves exactly as it should so I wouldn’t think it’s the controller

Hmmm ok. Have you tried to do detection again? Honestly i don’t know what to test after that. Maybe setup the firmware completely new.

I will try the detection again but I don’t think that’s he problem. I have already tried with ackmaniac 2.54 with Foc, no luck there.

I suspect some integral windup going on in some control loop concerning the requested torque from the esc. However, I don’t know what settings that are affecting this behavior. Maybe I should try changing the maximum duty cycle or maximum erpm or something.

Thanks for trying to help mate!

This happens to me also with the winning remote

Ive been looking through the code and found something suspicious to me. It seems like a maximum duty cycle of [-1, 1] is hardcoded into the duty cycle control in FOC. Shouldn’t it be like the maximum duty cycle here? In my case thats about 0.4. @Ackmaniac

I’m pretty sure this is to do with the remote. Both the nyko and winning remotes are very unreliable, they also tend to drop out a lot.

But i’m having a hard time believing that the remote can cause this repeatable behavior. Especially as it only appears in FOC mode. There are no delay in control signals when connected to the tool.

Have you try to put those Value at 0.01

I’ve tried them at 0.1 but no difference. Can try even lower when I get the chance

Maybe this could help you :

Yeah, okay ^^ Maybe that’s it. I’ll give it a go and see if that will effect the behavior :slight_smile: Tanks for all input!