VESC and nyko kama, what is going on?!

Hello!

So I went out to try my board outside for the first time today and it has already tried to kill me at least three times.

I have the Nyko Kama connected to the vesc. Soldered -> JST. It works flawlessly inside my home and did periodically outside as well. However it cuts out insanely often and it’s sometimes even hard to get the signal back, this has NEVER happened in my apartment (currently 3 meters from board and it’s constantly connected and everything works).

I have noticed my VESC blinking red 3 times on boot and once when disconnected. I cannot get any fault codes out of BLDC by typing faults. “No faults registered since startup”.

I redid the soldering on the reciever and it seemed to work for a bit, but then the board tried to kill me and it was back to being as horrible as before.

Suggestions? Do I live in signal mekka or what the hell is going on?

Edit: Also tried to wiggle the shit out of all cables to see if theres a loose connection on either nyko or power source, cannot get the remote to disconnect and cannot get the VESC to reboot by doing so… :frowning:

NEVERMIND THIS (woks fine when I disconnected the Nyko Kama): Noticed it just makes a click noise when trying to control through BLDC with keyboard which seems like DRV fail but works fine with remote and so does motor detection.

Doesn’t sound like a nunchuck problem, could be vesc is cutting out due to other reasons. Please post screenshots of your bldc tool screens. What voltage are you running ?

1 Like

Yeah I’m really confused about this since it seems to work so well indoors. Initial thought was definitely bad connection somewhere but having trouble finding one. Running 10S. Still having vibrations as main suspect though as the only time it worked really well outdoors was on some kind of flat stones. However sometimes it didn’t want to connect at all so…

It might be the VESC rebooting but I have also experienced it running away from me so that must have been a remote cut out, not VESC.

Edit: Can legitemately control the board on the floor while being 4 meters + and through a wall while indoors, outdoors is a disaster if it even decides to work at all…

How do you tell that it doesn’t want to connect ?

The LED on the remote just keeps blinking, then suddenly after a delay of half a second to 10 it connects again. This could be either because VESC turned off or the remote has horrible signal I guess.

At one point I got mad, left the street because as soon as I stood on the board it would disconnect (not even accelerating with it). While carrying the darn thing home 150 meters it was connected the whole way, don’t even know where to start looking for faults.

Also, it shouldn’t blink red 3 times on boot right? If not it’s strange I can not get a fault code out of it.

That does’t sound right. In my experience the nunchuck will not reconnect by itself, you need to push the s button to make it connect. At least mine works that way. 3 red blinks on boot is normal.

Oh nice (that sounds almost too happy :stuck_out_tongue: ), couldn’t remember the three lights from before so got worried the VESC was screwed up. Maybe it’s just the Nyko Kama remote or reciever that is screwing my life up, really hope it’s nothing worse.

I think my remote starts the “blinking process” automatically when disconnected, it just starts looking again (I THINK), can double check when it has stopped raining.

You are correct, it does not reconnect without pressing the button. However it seems to have bad signal or something. Using cruise control can be a bit choppy for example (probably dropping and gaining signal before dropout or something, just as if there was a drop and reconnection). Or just giving a little quick throttle and releasing -> board just keeps that speed until timeout.

If the problem even has with the remote to do. Don’t know how to progress really and now the weather is crap so…

If you post a picture of your soldering @lowguido should be able to see if it’s a good connection. He barely ever gets drop outs and he soldered. Most likely could be something else though.

Yeah pretty sure the soldering is fine. Went out again to try, worked sporadically, maximum 20 seconds each time before a minor drop. I will post a video in 10 minutes showing the behaivior (which after my latest test round also appears when at home). Only change was new batteries in the Kama (measured to be better than old).

Should not be the VESC cutting out, brakes are applied until the board comes to a stop.

sounds more like a VESC issue than a Kama issue to me, but yeah show me what you got anyway.

I have no clue to be honest. Here’s the video anyhow. This did not happen on benchtests earlier, it started happening after I went out for a test ride/swapped Nyko Kama batteries for BETTER ones.

As you can see the remote connection LED blinks whenever the bleep it wants :’(

Originally the problem only happened when outdoors, no matter if I’m on it or not. Earlier when at home I could control it all across my small apartment through the walls, outside it said “nono, you are 50 cm away, I won’t work”.

Edit: Just now the board is stuck on a constant blue led and the remote won’t connect at all because the reciever doesn’t realize the remote is not connected…

@lowGuido Not very visible due to hot glue but as mentioned, even resoldered today because of the problems. They stayed the same.

Can’t see the video. It’s on private.

Oops, forgot to press publish, fixed. Also, note the blink and the cutoffs when using the cruise control button.

Please categorise this topic. It fits in eboard electronics.

I think I have noticed that the closer I go the motor cables with the reciever, the more drop outs. Holding the reciever above motor cables and giving some throttle causes it to cut out instantly and continously. Most other people doesn’t seem to have longer cables and better placement though?

this thread needs more pictures. Y’all know I can’t reed!

Yeah, gonna have to go sleep now and hope it works better with the reciever away from the motor cables. Will take pictures tomorrow with and actual camera and not my cell phone.

That IS weird. Put a multimeter across VCC and GND while doing this exact test and verify the vesc 5v supply isn’t doing weird stuff before you start doubting the soldering.

So while the motor wires seemed to cause interference it didn’t help in actual riding conditions. Will try measuring the voltage later. I suspect you mean 3.3 V @trbt555, right?

@lowguido and then there were pictures.

Problem can be reproduced by tapping the circled antenna area with my finger. Starting to think the antenna has bad connection.

Small flexing gap, should it be there? I’m really starting to suspect the receiver is screwed for some reason.

The ceramic component is very slightly burnt from a soldering iron, in my mind that shouldn’t be the problem but might get one quickly later and swap it out just to be safe.