VESC "bad motor detection" problem

After assembling 2 brand new VESC’s one of the VESC’s is having trouble running the motor. When I try to detect the motor parameters I get the error “Bad detection results received”.

I have tried running the same motor through my other VESC which is working fine and It has no problems. I have tried multiple VESC firmware versions through multiple versions of BLDC tool and still nothing. This leads me to believe the problem is hardware related on the VESC. The green and blue lights are illuminated and I have re soldered the wires to assure there are no shorts or bad connections.

When I try to detect the motors or drive them I get short sudden jolts in the motor every few seconds.

  • I am running 2x 4.10 VESC’s with the 2.4 BLDC tool with the 2.3 firmware loaded.
  • Running 2 Enertion R-spec motors
  • I am using a Nyko Kama nunchuck

Here is the dialogue I get when I try to detect the motors:

have you tried re flashing the firmware? edit sorry I re read what you had said and you have tried that. disregard…

I had similar issue and latest firmware flash fixed it.

Mine was working fine but now I’m getting “drv8302” fault code in the Realtime Data tab, along with Failed Detection. If you go to the Realtime Data tab and click on “Active sampling” at the bottom left, what error does it show for you when you hit Up on the Nyko Kama controller? Mine now shows “drv8302”

1 Like

Can you take pics of your vesc causing troubles?

I’ve often seen, and done myself is bridge the middle pin on the fets, it caused similar issues.

Check the DRV pins for bridging, also check the fets left leg for bridging. If R28 is cold jointed it would cause these symptoms too.

Best case scenario is a poor battery or motor connection.

Lets see some high resolution photos!

Thanks for the troubleshoot tips, on the road for a few weeks, I’ll try and get some images up as soon as I get the chance.

I need a clear schematic that outlines what each component is called, Im nor sure what the components mentioned above are. Links would be appreciated.

Have a look in the BOM under All parts are assigned to specific locations on the PCB.

1 Like

@Moja did you resolve your issue? I have similar, although all was working fine when running 2.5, updated firmware to 2.8 and then got message ‘bad detection result received’ on motor detection, reverted to 2.5 and issue remains. VESC 4.10

How did you fix your problem I have the same issue.