Vesc brake always at maximum?

Hi guys,

i stumbled upon an issue with my setup. I cannot set the brake force, whatever number is set the force remain the same. For example i’ve set the motor min at 5A and the batt min to 0, and when braking the current reach 13A, the same current with much higher brake settings. Same results even setting the brake current with the control tab of bldc Tool.

I’m using an arduino to control the vesc through the RollingGeckos VescUartControl library, more precisely the VescUartSetNunchukValues function. It’s the master branch. On the focbox i’ve flashed the ackmaniac 2.54 firmware.

Are my config wrong? Or do i understand wrong the brakes behavior? Hope you guys can help :slight_smile:

Post screenshots of your settings. Are doing this on a bench or actually riding?

1 Like

I guess you see the high current only in the moment when the motor comes to a complete stop?

I’m testing on the bech. Is there some other relevant screenshots i should post? In the last screenshot I’ve set the current to 2A on the control tab and turn back and forth the wheel.

Red curve is motor current. You got that set to -30. Blue curve is battery current, that stays near zero. You probably cant spin it fast enough continuously long enough to produce any significant current back to the battery on the bench. That is more of a while riding kind of test.

1 Like

But even if I set the motor min to 2A, and using the remote gives just a tiny bit of brake, the brake force remain the same. I can brake but it always the full power of the brake, I can not adjust it

it’s because your on the bench dude. put your board on the floor and you’ll see how weak and gradual braking is

Below 3% duty cycle the VESC does a full brake. Doesn’t matter which settings you adjusted. Because at this low rpm’s it can’t detect the motor position. Just test it riding the board and forget the bench tests.


Oh … that makes sense. I will test and then report back :grin: