Vesc Can't connect to Pc

HI i plugged in the vesc usb and plug the battery into it yet on the bldc tool it doesn’t show any ports simply not connected. I checked device manager and it shows up as chibiOS/RT Virtual COM Port. Blue and red light is on whenever I turn the vesc is flashes three times and stays on. I downloaded the bldc tool from the vesc website where I type in my email and get the files. I tried switching usb cables but didn’t change anything. Please help asap.

I am assuming you gave it a few minutes for Windows to install the drivers before accessing VESC. Which light stays on? Blue, red or green. I think blue is power, red is errors, and green is for STM32F4 chip. The lights just for clarification that one or both lights are on after startup.

If the red flash 3 time at the start, it mean that the bootloader is instal, so it should be alright

update: mottor dectection works and vesc is connected everything works except the remote ocnnection. I have the 2.4ghz rc remote I set it to ppm I folowed the pairing insturction but to no avial it doesnt work.

What remote do you have?

TorqueBoards 2.4Ghz Mini Remote Controller

Which version of bldc .might need old Windows version download for it to sync up that was an issue I ran into but I’m new to this stuff so don’t know just a thought.

i believe 2.18

im using the enertion standard vesc what verison and firmware should I have used?

Did you watch jacobs vide about setup? he explains how to setup your controller. has it all,

yes i did but no matter what my controller isnt moving the hub motor

Post screenshots from bldc-tool please

Please check first if you have the 3 wires from right vesc to the remotes receiver connected correctly.

yes its connected correctly

Is the remote already binded to the receiver?

1 Like

yes i followed every instruction the diyelectricskateboard video said to do

did you reboot your vesc after setting the app in PPM mode… (and before setting the rest in the ppm tab)

which receiver channel do you have the vesc plugged into?