Vesc dead after motor detection

@onloop doing as described. Hooked up my vesc that I finally received today and plugged up the USB connected the motor turned it on. Read configuration worked. Went to do motor detection the motor jerked then said detection failed and began to flash pink and blue. Checked for fault and received a DRV8302 fault. From what I see that means a chip is bad and has to be replaced? Powered down checked all connections and all where connected. Tried my desktop-no joy Uninstalled and reinstalled- blinked a little different but then went back to the same thing. Different cable, power supply, checked settings - no joy Don’t have another motor or controller.

Not sure where to go from here.

1 Like

Post some pics of your setup and your settings in the bldc tool

What kind of power source are you using?

two 4s batteries in series so 8s zippy 30c.

The only thing I can think of is that whole topic of using low voltage for the first boot-up as suggested by Chaka here:

I don’t think I’ve read of anyone that’s actually fried a non-Ollin VESC from not using low voltage though. Perhaps someone who has a better eye for those short-prone spots on the PCB might be able to point out an area that shorted when you tried to spin up the motor. This thread sounds similar:

Put the max voltage to 57v and try again

I actually thought about and read that before and used my low volt to power up then connected my battery after. And as for popping on the xt60 connectors I have a 170 amp fuse I use to turn off all power so no worries there.

Do this, your max input is to low

Did you also change the original motor lead… Make sure you didn’t brake any of the resistor or short the mosfet.

1 Like

no go ghost rider.

Check your settings on these pages:

yes a soldered it straight to the board due to not having connectors.


but i couldn’t even get an original motor detection so this is just what was on here.

Use cmd shift 4 for selective screen shot on mac cmd shift 3 for full screen shot

Perhaps a fresh 2.18 firmware update and then try again? I’m no VESC expert and am just throwing obvious ideas out :slight_smile:

1 Like

Fresh firmware is a good idea. Check your max current ramp step on the advance tab. it should be .04

did it like 4 times.

i did and it is.