VESC doesnt work

Yeah yeah another VESC inop thread but nobody has posted shit about this one. Just got my VESC yesterday and am trying to get it programed and that’s where the trouble started. when i connect my VESC to windows i get the du du du sound and when i open BLDC tool i click connect and it says connected for about 2 seconds before going to “NO FIRMWARE READ RESPONSE” then disconnected. When i open device manager it shows uninstalled device ChibiOS/RT Virtual COM Port WTF?! is this shit? and how do i find a driver for it? Because that is the VESC it comes and goes when i plug and unplug the controller. The VESC just sits around with both a red and blue light both on at the same time while its connected, no blinking after the initial boot. I have the new firmware ready to install but the damn thing wont connect long enough for me to install it. Just goes to buffer erase timeout because the damn thing is not connected apparently. I have tried uninstalling the BLDC tool and reinstalling it with various power cycling of the computer attempts as well.

If you are using something other than a linux/ubuntu OS you may have an issue with the usb port id. Seems strange that the red led is on constantly??? If you purchased this from us, “OllinBoardCo”, we will take care of whatever issues you seem to be having. If not then hopefully it is just a port id issue.

Try finding the port id and entering it into the bldc-tool before connecting. Could also be a bad usb cable or usb port.

Bootloader issue? I don’t remember if that’s what mine did before I flashed the bootloader

so after extensive google searches for this thing I found some random driver, so of course I installed it and bam it worked. Not too sure why windows couldn’t find any drivers but whatever it is all hooked up and I took my first test drive this morning.

1 Like

i’ve seen a lot of USB 3.0 driver issues - a lot of the time just plugging into another slower USB 2.0 port seems to fix.

Do you know where you found that driver?? Im having the same issue

This worked for me -

During install it checks for the USB driver and installs it if needed (was needed for me). Then you can cancel the full setup after the driver install.