Vesc failed motor detection sk3 6364 245kv

Hi.This is my first time posting here. I am deep into building my first eboard. It is a vesc powering an sk3 6364 245kv. I am into rc planes and have built several quadcopters and my own cnc machine, but i am totally new to eboards. It was all going well until i went to hook up my vesc to the pc. I powered my vesc with a small lipo. 1000mah 3s. upon plugging in the battery it instantly started smoking. I unplugged within a second. Upon farther investigation i found a short where the positive power connects to the vesc. The vesc never heated up or smoked at all. I resoldered the power wire and fixed the short quite easily. The vesc connected just fine after. All was going well until i tried to do motor detection. The motor jerks once and then a few seconds later it jerks again and the red lights flash several times. I have adjusted the motor detection parameters within the limits mentioned in the faq but no combination will allow for a successful detection. I am at a loss for what to try to solve this. Could shorting the battery have blown the capacitors? I have not yet reflashed the firmware.

Where was the smoke coming from the first time? You should check the real time data (turn on active sampling) and run motor detection again. See what the fault code is.

The smoke only came from the lipo. It was a 20c 1000 mah so it wouldnt be able to push an insane amount of amps. The fualt im getting is drv8302

awww shoot, you might have a burned DRV, which is the most common part to die.

Could you take a look at or smell the DRV chip? It’s the rectangular one here

It’s likely it’s busted and you need to replace it.

The vesc never got warm at any time. Correct me if im wrong but if there was a direct short from the power to ground would the allow the voltage to cause damage? it seems to me that that would “dam” the electricity. Im a bit of a newb when it comes to circuitry. Would enertion stand good for it since it was shorted on arrival?

I’m sure Enertion will make it right, just contact their support. You should check out this thread as well.

I also have this problem with both my new VESCs. Do you think any of these are burned?



Both VESCs have a DRV8302 fault code? Did you check if the hall sensor pins are piercing the positive lead cable?

Yes both of them have it. I hot glued the hall sensor pins before I powered the VESCs for the first time.

@Jmak what does your vesc do when you try detection. My motor just makes a violent jerk then several seconds later it jerk again. I did get my motor to spin up by pressing the arrow key on the keyboard on accident. I had to disconnect it in bldc in order to make it stop.

Exactly the same thing. It jerks and then a few seconds later another jerk. But I can’t even press the arrow keys without a DRV8302 fault.

Hi, can we see a picture of the other side & also a picture of the motor connection points

Here is the pictures of the shorted power lead before and after I fixed it.

You mentioned that you set the motor parameters according to the FAQ. Did you also adjust your voltage cutoff limits for your battery size?

I set the minumum and cut off to 6 volts so that it would not be a problem with the 3s battery that I’m using to configure.

If your running 3s for testing, try to increase your erpm to 800 and your current to 8A in the detect parameters

If the motor spins up when I press the right arrow key in bldc it would seem to me that it’s not hardware. I wouldn’t say that it totally eliminates the chance of a hardware issue tho. How is it supposed to act when I press the arrow key? My motor spun up to full and stay that way. I had to disconnect in bldc to make it stop. I did try detection with a 4s battery with similar results. I am now running a fuse in line. It is quite a violent jerk when I try detection.

it shouldn’t run continuously when you press the arrows, it should only spin for as long as you good it.

I’m quite suprised that such an obvious short made it through quality control. Mabe before I “try it till it breaks” I should just contact enertion and see what their solution is.

My vesc failed to motordetect with a uncharged 5s, tryd with 10s and its worked out just fine!