VESC FAQ | Firmware Bug | Pre August 2016 | Please Upgrade

So i can use that BLDC TOOL version 2.18 for windows from, and don’t need anything else? That debugged version is some kind of file i cannot open, so i don’t need it since everything is included in that BLDC TOOL 2.18? Also about batteries- can i do configurations with my 8s lipo or better do 4s lipo or some laptop power supply?

you don’t need to open that file.

The standalone FW can be opened in BLDC tool only (with clicking the Firmware tab, then update and selecting the downloaded file form your disk).

But since I didn’t have the bug version of the FW 2.18 on my page you can just go the normal way too, selecting it in the downloaded BLDC Tool folder.

If the VESCs you have are made with genuine parts and pre-tested you would not need a laptop power supply. But if you are unsure it’s better to use it though.

It’s enertion VESC, so i think than i can do lipo, but 8s or 4s? And what i should write in BLDC TOOL if i’m using 4s, i mean, i still need to write numbers as it is for 8s, because my setup will be 8s 8000mah?

If you’re trying it with 4s you need the specs for voltage cut off start and end for 4s (in the Voltage Limits field). You can change it back later to 8s specs. Don’t touch min. and max. voltage there, it’s not necessary.

I want to try it with 8s, my question was is that safe? I want to write all things in BLDC TOOL for 8s, and go to skate. So as far as i understand: 1) connect VESC to motor 2) turn on remote 3) switch on VESC with 8s battery via xt90s anti spark loop key 4) connect VESC to pc via USB 5) at BLDC TOOL connect software connection 6) upgrade newest firmware 7) App configuration (which control mode should i use?) 8) do motor configuration Then what?.. Turn of battery and go for test ride? What should i know about braking adjustments and how i can make my board a little slower for first time, like beginner mode or something, till i get use to that speed!?

In general, your steps are correct, but switch point 8 and 7: first motor detection, then app config.

In the app config: if you have a 2.4GHz remote, take ppm and then “current no reverse with brakes”. After “write config” in the app section don’t forget to klick “reboot”.

All those points are described in the FAQ section here.

O.K. thanx a lot!

@carl.1 Is this covered by warranty ?

Hi! I have some issues with VESC. So i have enertion VESC 4.12, connected to BLDC TOOL, it even read configuration, so no problems so far! Then i tried to upload new firmware, i took it from 4.12 folder, it called vesc default bin. It showed than it uploaded 100%, but since it uploaded it disconnected from BLDC TOOL, when i tried to connect again it showed So what i should do now? Strange is that when i connected i think it showed that connected vesc had 2.17 or 2.18, but now it shows that connected vesc have 2.15 firmware. But my BLDC tool is supported for 2.17 and 2.18. But maybe VESC had 2.15 version of firmware already.

So I downloaded BLDC tool for 2.15, so everything working now! But i want new version without bugs, like 2.18. How can i upload 2.18 if it allows only 2.15? How does it possible that my VESC has so old firmware 2.15, i bought it maybe just 3 months ago? So it means that they sold me some old VESC or something? O.K. i don’t care if it’s 2.15 or 2.18 as long as it’s without firmware bugs. So how can i tell if my 2.15 version have bug or not?

download this vesc tool for free then use your current bldc tool to upload the bootloader from the link I’m going to show you: … It said the same things to me and I was still able to upload the bootloader then upgrade my vesc!! Just use the bootloader file from new link and upload the bootloader file through your bldc tool that is used for your wanted firmware!!

I have an issue though about my motor detection and I can’t even get my motor to make noise :unamused: