VESC - FAULT_CODE_DRV8302 - Cause?

Using the information in this forum, I built an electric longboard. I am using a Spacecell Pro3 (10SP3) from Enertion and a 6355 190KV motor and VESC BLDC Speed Controller from http://. I road 40 miles or so and then, earlier this week, the remote (torqueboards nano) just stopped responding. I took the board apart and used the BLDC tool to see what was going on and found after typing “fault” into the terminal I was getting the DRV error. I am working with to see if they can help but I was hoping someone could look at my settings and see if I made an obvious error. Nothing looks burnt on the board.

anyone see anything off?

Can you post pictures of your vesc? you might have a hardware issue and not a software issue.

Although, I’m not sure about running motor min at -80A especially when your only outputting -6a to the battery.

I sent the vesc back to http:// this morning, they are going to take a look since the vesc comes configured for my setup according to their website.

Based on your comment, what would be a better value for the motor min? I think this may be a hardware issue but i wanted to rule out an obvious setting issue.

Well I’m not really qualified to give optimum settings for the Vesc, I just recall reading that the motor min and batt min should not be too far apart. I don’t know if that theory still holds or not. I run my motor max at 80a and motor min at -40a and batt min at -10a I mostly use my brake to control speed or come to a gradual stop. I run my belts pretty loose which keeps me from slamming the brakes anyway. Really I’m not even sure that your motor min setting could be causing any issues. And I didn’t notice anything else wrong with your settings.

When I said it could be a hardware issue, I meant that there could be a short somewhere on the vesc that caused the DRV fault. Motor phase wires shorting together can also cause a DRV fault.