VESC firmware and motor issues

Alright so I have a big issue:

I bought a replacement VESC from tourque boards after my other one broke. And I received it a couple days ago. However, when i plugged it in to my BLDC Tool it says “The firmware on the connected VESC is too old. Please update it using a programmer.” So i asked the support guys for help and they told me to download the VESC Tool software. So I did so and updated the firmware following the instructions:


So I opened up the BLDC Tool and tried connecting it again and it still said the firmware was too old. So i tried it again to see if I did something wrong the first time, but it failed again . Then I realized I could configure it using the VESC Tool. So I ran some detections and tried configuring the VESC and nothing happened. The resistance is like 25,000 ohms which is way too high. And the fault reads FAULT_CODE_DRV. Also, when I try pulling the trigger on the controlling, nothing happens either.

Now im starting to think that it is a faulty VESC and I should replace it, or if it really is a firmware issue.

I will leave screenshots of the VESC terminal and Debug console to show the Faults and the failed detections if that’ll help at all.



I think I got this, Just need to confirm which Windows version you were using?

I’m using Mac OSX. I found download for the software for Mac.

Have you tried again using Windows PC?

1 Like

Yeah so I originally used Bootcamp to run Windows on my Mac before I found the Mac version. The version on that was Windows 10.


Now try using VESC tool to flash the FW of FOCBOX

What do you mean by “flash the firmware”

upload new firmware = flash the firmware.

Get that reading time up :slight_smile: this might have been avoidable

1 Like

I can try uploading a new firmware but i already tried like 4 times. All with firmware 3.38, 412

might need to replace the drv then. also correct me if i’m wrong @Deckoz but if you run the foc detection all the boxes for foc should be highlighted green. I don’t use foc on my tb vesc so I can’t give advice on that. I run hybrid bldc and my whine is actually not too loud. sensored

Yes all should be green

Yeah i was suspecting there was a faulty drv chip

@mgertner Then you have to get it to a DRV wizard for repair

Do you know any?

Depends on your location

Oh so it’s an actual person that you have to go to?

Hi All -

I am having a somewhat similar issue and havent been able to find an answer in any of the forums I have checked already - hoping someone here has some troubleshooting options - Ill try to be brief:

  • I initially built a single-motor board using mostly TB parts (motor, mount, VESC, etc.)
  • Used that board for 6+ months with no issues and then decided to upgrade to dual motor setup (w @psychotiller Six Shooters :slight_smile:)
  • Purchased an additional Vesc, motor, and mount from

Now here are my issues:

  • My VESCs are physically the same but have different firmware - i have tried several different ways to update the firmware on each one and continue to get errors. Most commonly I am getting this error:

"The I/O operation has been aborted because of either a thread exit or an application request"

I have tried updating the firmware via the VESC Tool, tried the normal update and tried the bootloader avenue - nothing works. I have tried a shorter USB cable, tried changing the settings on the port, etc., but I cannot get the firmware to update and therefore I cant change any of the settings to make my dual motor setup work. Getting very frustrated.

Anyone have any ideas? Ill try almost anything at this point.

Thank you!!! Ryan

By the way. I have spent HOURS AND HOURS reading in this forum so please do not use my reading time as a measure of my commitment lol. I spent most of the time reading before I actually created an account.

Didn’t get it right, you checked if there is a bootloader installed on the vesc?

You should always be able to flash the fw with a stl link v2. It’s about 5-10€ on amazon

When i start up the VESC tool is says there is a bootloader installed and to update the FW using the Firmware tab. But when I do that I get the Serial Port error I mentioned.