VESC Firmware Update Issue

I powered up my vescs, and while updating the firmware, ran into an issue with one of them.


I updated the first one by navigating to the firmware tab in VESC-tool, and selecting the hardware and the new firmware. It worked just fine.

With the second VESC, I followed the same process, but it seems to not be taking the new update. I get this error message when I try to connect after loading the update.



After some looking around, I think that it might be that my VESC doesn’t have a bootloader, but I’m not positive.

What do y’all think it could be?

Hi there,

I have the same problem with my (Flipsky) (ESC). As far as I can tell the bootloader (under the firmware tab) is succesfully uploaded to the ESC, but when trying to update the firmware the ESC restarts and only a blue led comes on and then I get the same error as you have.

When I unplug power and reconnect it, both a blue and a green led come on, and vesc-tool can succesfully connect to the controller again. However, after connecting vesc-tool gives me a message saying I need to update the firmware. I am hoping someone can help with this error.

what flipsky esc are you using? im just curious.

I have the same problem - I haven’t tried to load the bootloader yet because I wanted to get the board on the road (not risk bricking anything), and now it’s raining so the whole thing is on hold.

Isn’t @BarbaraZ a flipsky rep?

On the box it says it’s an HGLRC-Flipsky 50A ESC. It looks like this one:®-bldc-electronic-speed-controller.

1 Like

I do not know @BarbaraZ, but if she/he is indeed a flipsky rep it would be awesome to get a reply from her/him :).

Try this:

[email protected]

Good Luck, let us know the outcome.

hi did anyone have any luck here? I’m having the exact same issue

Hey James, I did end up getting it to work.

I had to buy an ST-link v2 programmer, and reflash the problem speed controller. Then I was able to load the firmware and get it to spin my motor

well that’s a pain! thanks for your reply… fingers crossed i can get this thing working!

I am still in contact with Flipsky service. They do provide great help, but no solution so far.

hi people the problems do still exist in 2019,any solutions ?