Vesc issue connecting one of two vesc's wont connect

So I was running my custom board all day and changing settings to get the tune right. I decided that the firmware could be an issue and went to update.

Im running a DV6 pro and tried to update to 6.02, one of the settings is to update all vesc’s on the canbus and reboot. I did that, let it reboot and nothing.

The main vesc I was plugged into no longer connects to my computer, however the second vesc does and has the correct firmware.

Now also the power button does not work and wont let the vesc turn on when its plugged in. The controller is also on this same wiring harness so I cant plug that in either.

Idk what to do, one vesc works and the other is just a brick, its shows up on the canbus as just an unknown device next to the recognized vesc. The working vesc does everything its supposed to and runs though setup of the motor and spins it.

I dont know if theres a way to fix this or did I just brick one of two vesc’s on the DV6 pro

There’s a new update? Other than that, did you first download the bootloader before updating firmware?

I’m not too familiar with the pro since it uses a custom firmware from makerx.

Edit: uhhh yes, you did brick your esc because of the 6.02 update. I just checked on it. I would contact makerx about it.

So the 6.02 update bricked the board?? I followed the included instructions for updating the firmware from makerx’s website. Also even if one worked?

Well I contacted makerx does anyone know if they can even do anything? Like can I buy a external boot loader like a Arduino one or something?

Even I didn’t know about it. If the other side works, then there might be a chance to save it.

I’ve heard its 50/50, but they do try to help out and will give you a shipping location. Other than this, I can’t really give more details since both of my escs are still working to this day.

You might find more help in the other forum however since the creator is currently active there.


ok so I managed to fix the issue with MakerX. The esc was not bricked it just needed a interesting solution I will then document here for anyone else.

I also want to say that I have to thank MakerX for the best customer support I have ever had and they know there product very well.


So if anyone else experiances this issues, the secondary ESC on my DV6 Pro was unresponsive and did not connect to a computer, only a blue light. So the problem I think was that I did not install a boot loader before flashing the firmware, as the upload bootloader function, has a upload to all vesc’s on CAN function. I dont belive that it works as from what I saw it only uploads to the one ESC for this board. So it uploaded the bootloader onto just the main ESC and then didint on the scecondary ESC. So then when I uploaded the firmware it bricked the second ESC.

So next was to use the SWD programer to flash new firmware to the bricked ESC from the main good ESC. I connected the DIO and CLK pins on the SWD connectors together. I used the included wire for one and then soldered the other connections to the pins of the second connector. Then just connect to the working VESC and use the SWD Programmer to erase and upload the correct firmware to the board.

This fixed my issue and has the board running perfectly, so thank you makerX for your help and I hope this helps another deperate owner

Someone else had similar issues. How did you manage to connect your swd programmer to the esc? From what connection on the esc to what connection on the programmer?

For some reason it won’t let me upload a image, but those pins I mentioned are on the board labeled, you just have to remove the cover and there the odd connector.

Okay. Hopefully you can show images of that when you are able to. I’m more of a visual learner.