Starting Tips | Ask Questions | Introductions | Categories

VESC Not Powering Motors After Heavy Riding


After riding my board for 4 miles, I came across a large hill which I was able to power up effortlessly on my dual VESC 10S setup. However, after successfully getting up the hill, the board slowed down and would no longer let me transmit power to the motors.

Thinking the VESCs potentially overheated, I let the board cool down for a few hours to try it again. After connecting the power and applying throttle, I heard a slight noise from the motors which quickly died out. Now trying to apply throttle I hear nothing from the motors.

Inspecting VESC’s further:

What I have tried:

  • One of the motor wires seems to have fatigued so I repaired that.
  • Using a multimeter, I confirmed that both the motor leads and motors are working properly.
  • Reinstalled firmware and ensured BLDC settings are correct. Using GT2B I am able to confirm signals are being received by the VESC
  • No fault codes in either VESC
  • VESCs were connected via CAN-BUS, I have de-coupled and tried each one separately (still doesn’t work).

I am no longer sure what to try.

Thank you all in advance for any help you can provide. Before the VESCs broke, I absolutely loved them! That makes having the board on the bench all the more difficult.

Quick inspection, it looks like this motor wire broke:

and this lead to the battery looks like it cooked:

Are you using the same gauge wire for positive and negative on the battery wires? it looks like negative is a higher gauge. I would try replacing it either way.

Hi guys. What to do if my VESC did not receive any signal from the transmitter/receiver? and BLDC tool showing bad detection?

youmentioned that you did fix the broken phase lead, but what about that power lead @treenutter mentioned? It does look pretty cooked. You may want to replace all your power leads with 10 gauge wire and then diagnose further.

This sounds silly but it happens in cars all the time. Cant start your car, but for some reason the accessories are still able to light up the dash. Starter benches ok, solenoid clicks in ok, battery tests ok…Why? because the starter wires are burned up. They only carry enough juice to dim the lights and half ass start the starter, but not enough to turn over well enough to fire up the engine.

Thanks for your replies.

Yes, I did already repair the broken motor wire.

I may attempt to replace the power leads when I get some free time. I find it silly that the wire leads were such high gauge though that they could potentially burn up (came from the first Enertion 4.10 batch).

I think the motor wires could also be improved by using something with a greater number of strands to prevent fatigue failures after hundreds of miles of vibrations.

good quality flexible wire will help, but i think you are trying to angle the motor wires too much. That torque with the vibrations would be why the wire broke from fatigue. You could also angle the soldered wire towards the wire path and not have so much solder wick up into the wire so it can remain flexible.

When you swap the broken wire and the burnt wire - does it work? If not, what errors are you seeing in the BLDC tool?

Fingers crossed it’s a simple fix like this! GL!

Just swapped out the wire in question. I don’t think it was burnt out. The discoloration was probably just excess flux.

Powered on the VESC and still nothing. Here is the realtime plot when I blip the throttle:

Could something inside the VESCs be burnt out?

1 Like

are you able to see any error codes display in the realtime data tab? See above, in the lower left there is a “Fault Code” DRV8302 error.

Also - In the realtime graph area i was seeing a DRV error, then in the terminal tab i typed in “fault” and it would return a fault code. I needed it to have failed/errored recently to see it return a code in the terminal, but that’s how i confirmed the DRV chip was dead.

1 Like

Shoot I just packed up for the day. I will try and check tomorrow. Thanks for the tips!

I also have the same issue with my vesc. No faults listed in bldc for mine. I have replaced all wiring twice and still no luck. Luckily I have another vesc coming in the mail and I will be sending my current vesc back for further diagnosing

I finally got it to show a fault codes using sl33py’s method after a few seconds of throttle.

Here is the first VESC:

Here is the second (formerly slave) VESC:

Looks like they are both dead :frowning:

1 Like

Hi guys, I have tried mine, both realtime data and the terminal doesn’t show any error. Does this mean that my motor dead? but why when I push the throttle, the esc green light doesn’t blink, it just stay. What to do next guys?

1 Like

After several test, yup, it shows fault code DRV8302. Therefore, I ordered DRV8302 from Texas Instrument and will try to change the IC based on Benjamin Vedder tutorial video.

1 Like

Is it suppose to be shorted together?

That’s normal, but could it be that your VESC is one out of the first batch (May/June) which had some problems?

Yes, those are fine. Is this a photo of your VESC?

I got the picture from one of the thread regarding vesc. Still, mine is the same as the picture. pin 54 & 53 and 51& 50 should be shorted together.

@elkick chances are the problem comes from my careless arse which forgot to heat shrink the motor lead connection.

@chaka so if I change the pic drv8302, I need to short both pin like in the picture?

The pads under those pins are already connected so it isn’t a big deal either way.

1 Like

ah thats clear things up. Cheers

Looks like those cables are low strand count wire similar to what you would get at an automotive supply. You definitely want to switch those out for some high strand silicone wire. It is common for the insulation to melt on the low strand count wire due to a much larger amount of resistance too.

Anyone installing one of these units would serve themselves well by replacing all cables.

1 Like