Vesc not working - Error ABS_OVER_CURRENT

Hey guys, Yesterday I went to go re-program my braking and before touching any settings, there was a blinking red/pink light.

When I went to detect motor again, active sampling had an error code: ABS_OVER_CURRENT. Upon rebooting the vesc and trying the detection again the motor just clicks.

Fault : FAULT_CODE_ABS_OVER_CURRENT Current : -144.0 Current filtered : -137.0 Voltage : 20.80 Duty : 0.65 RPM : 300.6 Tacho : 2 Cycles running : 71 TIM duty : 4038 TIM val samp : 2112 TIM current samp : 5208 TIM top : 6192 Comm step : 3 Temperature : 31.42

I’ve checked all 3 phase wires and they’re all perfectly fine.

Any help would be appreciated guys.

Motor: 5065 BLDC outrunner motor 3-8s 80A 1600w 270kv

Battery: 24V 60A (18650 cells)

The vesc I’m using is one with a heatsink.

140 amps? Geeze, what setup are you running? I’m lucky if my SK3 will brake at 60A, but still. If those numbers don’t match your motor then you know the problem (the motor).

How do I adjust? Two days ago everything was perfectly fine

What motor, what batteries? 140 isn’t normal for a single drive, but only your motor’s specs can tell for sure.

You might want to check “SLOW ABSOLUTE MAX” in BLCD tool, too. That introduces a mean-filtering delay to the abs_current value which can keep this from happening. But still, 140 amps is alot. Perhaps you have another motor to test with?

Post your settings or screenshots of the BLDC settings :slight_smile:

I tried a different motor, 320Kv but still the same result

Here are the settings:

I have no idea why it’s 144 A

Motor: 5065 BLDC outrunner motor 3-8s 80A 1600w 270kv

Battery: Custom welded 18650 cells (24x) 24V at 60A


40 amp batt max and motor max. where did you get your vesc ?

Came in contact with the guys at Arc Boards EV (from kickstarter).

They had a surplus of Vescs for their boards so I managed to get them to sell me one.

depending on what version of the vesc hardware that was used (yes, all vescs are not equal) the amperage max will vary. Try lowering both of the motor max and batt max vaules until you stop getting that error. More times than not, the error you are getting is indicative of too much power being used / requested. Vescs can be delicate which is why their is such a big difference in price for some vescs over others. I found 22 to 25 amp max batt will usually result in way less errors/issues on older vesc hardware.

Try setting ABS MAX to 150 or something (just for a test or two) and see if the motor will run at all. If not then it’d seem like your problem isn’t with older hardware or overpowered motors.

I had to replace the drv chip on a Vesc when it had that issue.

I’m guessing you’ve got some mad soldering skills then ;)?

Where’d you get the chip?

It’s actually not that hard you just need the right tools. I got the chip from mouser.