VEsc only blue and green show up light not connecting to bldc tool/Partly solved

Any one can help where to check for drv error also it is only showing blue and green light what does that mean , i know my drv is blown but where to check in bldc that “drv error”…

Try in bldc tool / terminal and type in faults

My vesc isnt connecting with computer

Its showing no firmware read response

Try another USB cable Some USB cables only supply power, and don’t have the extra data wires.

Mine is from ardunio nano, it is a data cable for sure

It is data cable

Showing no firmware read response

I had similar issues when I shorted the canbus. Maybe @JohnnyMeduse can help you

Also it might be worth installing some usb drivers for the STM32, just in case.

I was actually thinking that , will try now

installed drivers still shows no firmware read response

installed drivers still same issue

why are the blue light and green leds on vesc for?

It worked , i typed faults it shows fault code none

Blue is power, dim green means it’s running correctly. Bright green means it’s outputting to the motor. Red means errors, three red flashes means DRV error specifically.

no such thing , its showing no faults since startup

there is no red led is flashing, there is dim green light, but there is hole in drv for sure