VESC Programming Problems

Hi guys,

I finished a couple VESCs about a month ago and the first one wouldn’t program but the second worked fine until the positive lipo power cable shorted out i suspect. After looking at @chaka VESC repair thread I replaced both the DRV and ST micro but I can’t seam to program it or upload a bootloader now! I just get the error shown in the screenshot.

Error: read version failed in procedure ‘transport’ ** OpenOCD init Failed **

This is what i get with both boards, I’ve tried a different ST Link V2 programmer and its exactly the same. Would anyone be able to help me out?!

Cheers, Jack

Your pin order is a little off. Change the black wire from GND to SWIM on your stlink and you should be able to flash the VESC.

From the photo the clk and gnd pins look like they may be shorted with a bit of solder too. Hard to tell from a photo.

@chaka Hey thanks for the tip however Ive just tried it and its no different :frowning:

Im running Ubuntu 14.04 through parallels on a mac, would that affect anything, it strange as it worked previously with the same setup.

Cheers, Jack

I haven’t read about many people using parallels. Try a VM for Ubuntu I have seen that work. Maybe @jacobbloy can shed some light.

i personally use a vmware fusion but it should work the same. it would be more some thing like you haven’t connected your usb device though the vm correctly as some time its set that your mac is preference.

but i don’t remember ever seeing this error, if you can’t get it sorted vedder has his own forum connected to he would be the best to look at this one.

I programmed the fw and bootloader of my vesc on a mac w parallels and no problem at all.

When i had that error message, it would usually be hw related

Verify that your wires aren’t shorting through the solder mask, by the picture they seem to be lying directly on the pcb

yeah its strange because it worked for me before, I have replaced both chips on the board and the solder joints look fine. However would anything else have been damaged/things to look for on the hardware side?

Thanks for everyones help so far! Cheers

Do you get a blue light when you connect the stlink? If not then you have a hw problem.

Yes Blue light comes on when plugging in although on the other board (which previously worked fine) it doesn’t but i think thats because i soldered the LED backwards. I was in a rush, don’t judge!

If the blue light is on does that mean its defiantly a software problem then?


Make sure you are on USB 2.0 and not a USB 3.0 port. 3.0 seems to have issues.

Unfortunatly the answer is no, you could still have hardware issues. sometimes it is because of a microscopic bridge hardly visible with 5x magnification. Check the processor thoroughly, if you were able to flash a vesc with the same setup previously then you most likely have a hardware issue.

Haha what a nightmare! I just want to start riding again! I was getting some errors when I reinstalled Ubuntu about OpenOSD not being found, and my MacBook Pro does have USB 3.0 which might be a problem according to @torqueboards although I still can’t forget about the fact that it did work before. So thats telling me its hardware as well as @chaka

I know a few other people are having this issue but I think it may be caused by different scenarios. Hopefully ill get there soon, my new motors should be arriving this week!

Thanks for the help guys :smile:

@Jack, if it’s any consolation, I just finished two VESCS on the PCB’s I got from you and I have exactly the same problem. I have the same ST-LINK V2 as well.

I don’t understand why you’re connecting pin 6, this is an unused pin:

Should I be getting any of the LEDS on the VESC to light up when I connect the programmer ? (I may have a short somewhere because the programmer conks out when I connect the 3.3V pin. No LEDS.)


Yeah I had that issue on one of the boards I soldered. You’ve got a short somewhere on the 3.3v line. Test the regulator with a multimeter to be sure.

I’m not really sure what’s up because I had it working fine on my boards before. I think my hand soldering techniques could do with some work!

A few lessons learned: after soldering a whole bunch of ceramic capacitors it’s very easy to forget that the two Tantalum capacitors have a polarity. Same thing for the LEDs.

The schottky and tvs diode are also polarized.