VESC stopped working, fault led blinking, not recognized by computer, help

Hi you all, I encountered an problem with my board. It’s a bit long story but I hope you could help me.

Couple of days ago I rode to my friends house for a good 5km without any problems and the board had worked well for the past couple of months after I built it. But after an hour chilling, I decided to let my friend test my board. I turned it on and gave it some gas on my hands and it worked as usual. But after my friend stepped on it and rode with it for about 20 meters it just stopped working. He told me he didnt hear or do anything strange.

I tried the usual, restarting it and the controller etc. but it just didnt spin the motor. I used my friends computer and downloaded the latest bldc tool (I use the old one on my computer) and updated the vesc firmware as the program told me. After the update bldc tool was working as intended. I then proceeded to the motor recognition part and made it to run the motor test, but nothing happened and after a while it told me some fault with the connection on the lower left of screen. I checked all the connections but still nothing. So I gave up for the night and the next day I charged it full and didnt touch it for a couple of days (I should have tried to check what fault codes it game me).

Today I turned on the power but still nothing. I Connected the vesc to my computer and turned it on but my computer doesnt recognize it. Vesc blinks red three times and pauses for a moment and continues the cycle. So there is some fault codes but I cant see them because my computer no longer recognizes the vesc. Also, the area around the leds heat up very much, not burning but very hot(touching through the transparent heatshrink). I use 10S2p battery pack

I bought my vesc and motor from here: products/torque-esc-bldc-electronic-speed-controller

Does it have something to do with the firmware update? Do I have to update the bldc tool on my computer also? Is the vesc gone forever? Should I charge the new vesc from my friend? :laughing:

need help :sweat_smile::disappointed_relieved:

1 Like


Well I managed to get the vesc connected…