VESC Tool / Xenith 2.1 - motors randomly change direction on startup

this is a fresh install and first time I set up the board with VESC Tool. everything is looking good and working as expected, except one annoying issue :

  • whenever I power on the board it’s a lottery whether it will drive forward or in reverse, sometimes it takes several power resets for the board to travel forward, once it starts travelling in forward direction it works perfectly fine the entire session, until I power off, then it becomes a lottery again on next power up.

I wonder where in the settings to look for what may be causing this. I’m running FW 5.2 on my Xenith 2.1 with Maytech 6374 170kv motors, remote is Flipsky VX2 Pro.

I set up everything with VESC Tool 3.0, following the motor setup wizard and everything was behaving fine and motors were spinning in correct direction during the setup process.

When this happens, I can go in the application and change change motor direction to whatever I need, but then still on next startup it randomly decides on its own which way the motors would spin.

Any suggestions ? thanks

1 Like

so I found that the change of motor direction on startup is actually not random.

when I power on my remote first before the board then the motors spin in correct direction. however when I power on the board before the remote then the motors spin in reverse direction.

I still think this is not normal and motors should always spin in correct direction every time.

any suggestions ?

Did you check your pwn/uart settings? You probably have something that changes the motors direction according to the board’s angle and location of the xenith esc. Sounds cool, but can get very annoying if you turn the board on first.

I’m not sure about my statement though. I don’t own a xenith.

@LeonCamero well, I have no idea, this is my first build ever, I can certainly go over the settings again, I used YT tutorials and VESC Tool wizard to set up my board initially.

are you saying modern ESCs have built-in gyro to know board’s angle/position in 3D space ? I would hate my eboard to ay on me :slight_smile: and change the motor direction in the middle of my ride.

Deleted my old response because it might not be the esc, but the motor wires.

I would check this out since this was his issue. This and the PPM/UART settings to be safe.

@LeonCamero I don’t think I have a same issue as this guy, this is fresh build and all wires were soldered properly and sealed in heatshrink, secondly if it was the case then I think only one motor at a time would be affected, but it would be like 1 in million chance that it happened to both motors wiring at the same time, every time.

surely it must be in the settings somewhere but I ran out of ideas.

1 Like

If you have figured this out, do send out the solution for it. I haven’t had this issue myself and am unable to replicate it on my end. I’d love to know the fix if this ever happened on my end.

Apparently it’s the motor wires and how they’re plugged in. But since you are using vesc tool, this doesn’t seem to add up…

if I figure it out, i’ll post solution for sure. also, the other reason why I think it’s not wiring is the fact that it only ever happens when I power on the board while the remote is still off. if it was in the wiring I’m sure the order of remote/board power on wouldn’t matter.

@LeonCamero ok I got it sorted out, trial and error method. there is the VESC remote general tab (under App settings) where one of the options is “Control Type”, by default this is set to “Current”, I changed that option to “Current no Reverse”, it fixed the issue, now it doesn’t matter in which order I power up the board or remote first and second, it’ll never ever go in to reverse.

in theory it shouldn’t matter whether you leave control type selected as “Current” because I’m not selecting the reverse function on my remote anyways (the “Z” button) but what I think is happening when I power up the board first (before the remote) the controller has to make a decision whether or not “Z” button was pressed and in the absence of remote being active it just doesn’t know and I guess the developers decided the default action should be “reverse” for some strange reason.

by changing the Control Type to “Current no Reverse”, now the reverse can never ever be activated even when I press the “Z” button, and likewise when the controller starts up before the remote it doesn’t matter whether it “thinks” the “Z” was pressed as the Reverse is completely disabled anyways.

1 Like

Interesting. For mine I use current hyst reverse. Glad you’ve found your issue with some trials. I couldn’t do it on the hoyt.