VESC wont connect to VESC tool

I have a Ollin Vesc that I have used before without issue, but when I went to reconfigure the settings, it wont stay connected and then wont connect at all after it disconnects. I got this: vescoof I updated my VESC tool with no luck. I am on a windows computer. What could be causing this, and how do I fix it?

Change the cable, check if everything is plugged in correctly and the port is not damaged.

I tried multiple cables, and there is no visible damage to the port,

I know you said you checked the drivers, but maybe non the less give this a try

tried this on two separate VESCs having this issue with no luck.

Did you try a different computer?

tried three different computers with multiple cables and made sure everything was up to date. No luck with an Ollin or a Tb vesc

Maybe contact ollin about it just to see if they have any idea why.

1 Like

Does the blue led light up?

If so, maybe the firmware is corrupted or bricked by some other means.

Do the computers recognize the VESCs are USB devices?

not from what I can’t tell; I just updated the firmware. yea it lights up and the computer does not make a sound when t is piggies in or taken out, so ig not

Does the green or red led light up as well?

Have you tried wiggling the connector around in the mini-usb port? On some of mine, the contacts have worn out and I have to shift the connector around a bit for the connections to make contact.

Wait you updated the fw? Which file you choose? Could it be you uploaded the wrong fw?

@Gamer43 I’ll check on those lights later or tomorrow and yea I’ve tried wiggling it around @Andy87 I update through the vesc tool and ik I chose the proper fw

But how you updated firmware if you can’t connect? Does it mean before the update you could connect?

VESC tool doesn’t actually update firmware sometimes.

To ensure the correct firmware is on the VESC, you need an St-link and the appropriate connector. There should be videos online on how to do it. St-link clone is 6 dollars off ebay, or a proper one is $10 from Digikey or Arrow if you buy a nucleo board (st-link is embedded in the nucleo board, needs to be a nucleo-64 or nucleo-144 board)


the vesc would connect and disconnect if I tried to program it

still don´t get it. so you had a solid connection first. than you updated the vesc and now you can´t connect anymore? or you had a bad connection and with that bad connection you made a fw update?

Have you written to it and set up the board to ride? That is how I took it was that you had set it up first then were going back to make adjustments. What firmware did you load from which hardware bin

@Andy87 The connection was shotty, but it would reliably connect to the vesc tool. It would get kicked if I tried to do a motor detection. I only updated one of the vescs, as the other was up to date. Both vescs had this same level of connection. @briman05 I hadnt been using one of them and the other I got with about 20 miles on it, and was using it for a small single build im working on. Not sure about the firmware, its just the newest version from the vesc tool from vescproject.

Pls can someone point me in the right direction. I have wired up my new dual vesc 6.6 which had both blue & green lights working. I was setting up vesc on vesc tool & now on the usb 1 side of vesc green light is not working & now will not connect to computer. Can & how can I get this working again.