VESC wont connect :(

'Could not read firmware version. Make sure that the selected port really belongs to the VESC. ’ This is the error message I get with both the BDLC tool and the VESC tool. It connects for a few seconds and then disconnects. I’m not sure on what to do and no google searches have helped me out. All help appreciated. Thanks in advance!

1 Like

Try a different cable.

Pretty common. Change com ports wiggle cables turn VESC off and on then repeat until successful. Auto connect wizard works better than re-connect. And change cables.

Make sure the following 1: Your USB cable is not charge only cable, it must have to be Data cable 2: Make sure the COM port driver is registered in the system, In Windows See Device Manager (Under Ports and Coms) 3: If you get an Yellow triangle with ChibiOS in your Device manager please use below link to update the driver

Let me know if this helps, If you are still facing issues, I would like to help you virtually/remotely

1 Like

What @CarlCollins said a common cable that I have found that works is a PS4 remote cable. That is what I used to configure my vesc. Would be handy if enertion used one of the data cables as the charge cable for the nano-x remotre. Kill two birds with one stone.

1 Like

@briman05 As Original FOCBOX is no longer available now and Unity uses USB-C, I think we don’t have to use data cable for NANO-X charging :slight_smile:

True now but it would have definitely have been a help to have them included cause I bought both at the same time and found myself trying to find every micro usb and trying it and that is hard when I use all apple products

1 Like

I agree, That’s really a hassle but if you are an Android user then you might be lucky

Yeah but I prefer apple as I can air drop pictures and videos that I have edited on my mac right to my phone so it is easy to transfer large files.

1 Like

@CarlCollins I tried all of the following but it still not connecting. It gives me the following messages with auto connect and manually connect PFA the images. Thanks in advance for all your help.

VESCfirmwareError VESCError

What type of vesc are you using

It’s a vesc 4.2 maytech I think .regardless, I solved the problem. It just needed a firmware update. For a sensorless motor though what mode is better (I’m using sk3): foc or bldc

1 Like

Are you trying to configure this while having two Vesc connected to your battery?

I found out that my split connector that connects two focboxs to the battery was faulty causing one focbox to have a solid red LED. What I did was disconnected one of them then plug the the otherit to the battery. I powered it on using my loopkey. Solid RED LED went away and connected right away to my PC.

I, since then, made another split cable (parallel) to power both of my focboxs.

nah its a single VESC

I would do bldc unless you are using very conservative settings so foc doesn’t blow the vesc

Conservative in the sense low amp limits?

Yes foc mode puts more stress on your mosfets compared to bldc.

ahh gotchu. Also, for the battery max current limit- what do I put in? I’m using a 12s 5000mah lipo (no bms) with 60-120c, so on paper that’s a max discharge of 300-600A (correct me if I’m wrong). The vesc documentation says to ensure that the max battery current shouldn’t be more than what the battery but does not mention the constraints on the VESC itself. Mine is rated for 50A max continuous current and a higher burst (I forget the number). So should the max battery current draw be < 50A?

Hello, I am having the same problem. But I’m not sure how to download drivers as when I look at device manager I have no COM ports at all. My vesc isn’t being recognized by the tool and I get the same connection error message that he stated too.

Looks like you might be using Wrong cable or wrong port, please double check