VESC won't smoothly drive a SK3-6374 motor in a custom Sinclair C5 project? Please help

I have a VESC issue which I’d be so grateful if someone could be help on and highlight the error of my ways.

I’m using an SK3-6374-168kv motor off 8S (32V) to power a small electric trike. In fact, it’s a ‘Sinclair C5’ if anyone remembers these? :slight_smile:

The Sinclair C5 has 16” wheels so the motor is geared down 15:1 to provide a top speed of 17 MPH (off 32V); easy for a 2000W electric motor?

Before the VESC I was using a huge Castle Creations Phoenix Edge 200A ESC. This worked ‘ok’ but I got that nasty ‘cogging/stuttering’ sound when starting from a standing-still, or if I opened the throttle too quickly when on the move. When it wasn’t ‘cogging/stuttering’ though, the Sinclair C5 accelerated rapidly. Using this ESC’s data-logging capabilities, at times the motor was shown to peak at 200-300A though!

After doing some Googl’ing I stumbled across the VESC which seemed to answer all my prayers. However, try as I might it’s proving to be much worse than the CC Phoenix Edge 200A ESC

I’ve read all the FAQ’s and watched all the videos. Every configuration step completes perfectly , exactly as documented, but the end results are just very poor.

The motor is EXTREMELY jumpy /stuttery and the VESC easily cuts-out when the current maxes out at my pre-configured 80A. This confuses me, as I thought the VESC would ‘manage’ the current up to the configured maximum, but from the live data you can see it just goes straight to the max configured current (80A) and then after a jumpy/stuttery 3 seconds, cuts out.

What is happening? Everyone is saying the VESC is silky smooth from stand-still, but my experience is the polar opposite? Even when I’m on the move when I try to gently accelerate the motor jumps and shutters. With no load on the motor (i.e. the rear-wheels lifted off the ground), it’s perfect.

I would be delighted to share my config file if it would help.

How much does this vehicle weight? Which remote are you using? How does driving feel after you pushstarted your vehicle?

Im pretty sure 80A is over the VESC ratings

1 Like

Thanks for your reply!

The vehicle weighs 45kg (100lb) - I weigh 77kg (170lbs) - so approx 122kg (270 lbs) all inc.

To put things in context, when the Sinclair C5 was released in 1985 it had a tiny 250W / 12V motor and was capable of 12-14 MPH. It was also advertised to take a rider up to 95kg (210 lbs) in weight.

The VESC control input comes from a PPM signal (although why all the VESC docs/software call it PPM I’m not sure, as it’s PWM). For testing therefore I’m simply using a servo-tester.

Even from a ‘rolling-start’ it’s no different. For example, if I get the vehicle up to 5 MPH and then open the throttle the motor just cogs/stutters/jumps for a couple of seconds (accelerating the vehicle marginally) and then the VESC cuts out, presumably because it’s maxed out at 80A for too long. If I wait a couple more seconds, the VESC will work again.

Yes, I think it’s officially rated to 60A, but I simply thought I’d try upping this slightly to 80A since I was getting no joy at 60A.

60A @ 32V (1920W) ‘should’ be more than ample though… if it works.

Would it be possible to use twin motors in this thing? I would try a lower KV motor, and if possible, two of them. I’ll bet a pair of SK3 6374 149KVs would do it. I’ll bet you could get it to start from a standstill then as long as you weren’t on a hill.

It just seems so odd how a 30-year-old brushed 250W / 12V motor can do it with ease, yet a correctly geared (15:1) 2000W 32V brushless motor, can’t ?

By doubling up the SK3 6374, I would be chucking 4000W (over 5HP) at the problem… to do 17 MPH ?

I must be missing something, as all these videos I see of folk’s skateboards pulling away smoothly and quietly (and probably geared for faster than 17 MPH), and yet mine can barely get this vehicle moving at all.

So confusing :pensive:

When the VESC is set up perfectly, you have good and smooth acceleration, even from a standstill. The problem is to get to this sweetspot. Using a remote with only a small lever travel like the Winning remote, you only have a very small “window” between stuttering and the VESCs failsafe. In my case this window is only about 2mm on my Winnings lever. Even with no load on the deck my VESC failsafes when i push the remote too fast.

Don´t know your servo-tester but i assume you set it up correctly to match 0-50-100% in the “Display” area of the PPM Tab in BLDC tool? Do you have a “real” remote like the GT2b to test your setup again?

How many teeth do your gears have btw?

The Amp rating of the VESC (or any ESC) is all about temperature. From Enertion’s site: “Up to 240A for a couple of seconds or about 50A continuous depending on the temperature and air circulation around the PCB”

So you can burst up to 240A without issue for hard acceleration or braking, and cruise around 50A. But if you put active cooling on the VESC you can push past that.

Thanks again for your message - I truly do appreciate everyone’s thoughts on this…

Indeed, my PPM (cough PWM) is correctly set-up and displays correctly in the Display area. I’ve tried “Current no reverse” and “Duty cycle no reverse”. The servo-tester requires a full 360’ rotation to operate the throttle, so there’s actually quite a lot of resolution there.

On the face of it, if yours is failsafe’ing too, does this not suggest something isn’t quite right there too? Sorry, just thinking out aloud now :slight_smile: If the VESC cuts-out due to hitting the max current configured, why instead does it not just ‘manage’ this by automatically backing the current back down?

My gearing is actually two fold… 12:60 on a belt and then 9:26 on a chain, so the end result it’s actually 14.44:1

That’s really great insight Matt - thanks for sharing this.

I’m guessing the VESC will protect itself from overheating?

I think that my current limits in the BLDC tools motor configuration are set too conservatively, but since i never accelerate from standing still and i don´t have problems with it while riding, i don´t waste time seeking for the cause.

Maybe @devin can help here since he´s the expert of the VESCs current settings and in getting much torque at low rpms.

@ian.davidson just checking - did you run through motor detection with BLDC Tool?

If it’s one of those big brushed motors they have more torque than brushless at least from a standstill. For something so heavy sensored motors might help but dual motors would be better to distribute load.

What are your max input voltage and cutoff start/end values?

Could you please post some screenshots of your values in BLDC/FOC and Advanced tab?

It might be easier to help you that way.

I assume it would, the VESC is pretty smart and has lots of safety cutoffs built in, but I don’t know for sure.

Actually @ian.davidson is the one who needs help since he started this thread. I´m almost happy with my setup. Don´t want to mix up things here.

Sorry chaps, I’ve yet to work out how to ‘quote’ a preview post here - but yes @treenutter, I’ve been through every set-up process possible with BLDC, any every process completed perfect, as described in the FAQ, to shown on one of the instruction videos.

@titoxd10001 Ironically, one of the reasons the Sinclair C5 was such a momentous failure when released in 1985, was becuase the 250W electric motor was so under-powered, but then that was (and I think still is) the ‘legal’ limit for electric vehicles here in the UK (without tax, licence etc.)