Wheels brake locking in FOC right before dead stop

I’m runing the latest v0.86 version of BLDC tool in FOC and Focboxes.

Braking is ok but if I continue braking right before a dead stop wheels lock and i get thrown forward, it seems to be a common issue.

How have you guys fixed this?

1 Like

By running BLDC mode.:wink:


I’m not sure what happens on BLDC but it gives me hall sensor error only on the slave vesc!

I had to go back to FOC. After testing I found the brakes to be much weaker than previous version, even at batt min -25A and motor min -60A

I run BLDC No sensors No canbus (I use split ppm) And I get no problems Good torque Good speed Good brakes Just kept it simple

1 Like

I had the same thing in Foc and fixed it by lowering the Motor Min. It will still work well enough at high speeds but not as crazy at low speeds. Play around with it

1 Like

@Eboosted did you ever figure this out? I am having a similar behavior on ack firmware hybrid mode 12s5p. Not that bad at all really, just a little annoying. I would love for it to be gone though.

No. I’m still having this issue.

@ackmaniac told me the issue was low speeds ERPM detection, the firmware just reads zero ERPM and brakes go into full brake

Hmmm, unfortunate.

I had the same issue in BLDC, and it can be fixed by changing the setting “max ERPM at fully brake” to a lower number.

But I don’t think FOC gives you this same setting to mess with?



Yeah, FOC does not have that feature :disappointed_relieved:

1 Like

It is odd. I would prefer it never going to complete stop than locking up at 1-2 mph. But I’ll get used to it.

I got used to it but everytime my GF rides it, she complains. It’s just not perfect as I’d like.

The problem seems to not happen on the Raptor 2 though, they are runing a modified @ackmaniac FW

1 Like

It really makes me wonder. As soon as I felt I thought of your post.

There are many dual 12s 6374 builds around. But I don’t see much at all mentioning it besides this…

I am going to get into the settings a but more later. I have to pull off my enclosure anyway as I have my BT module (standard, not METR) hooked up and can connect to the board, but I am getting no telemetry. Gotta go figure that one out.

Also, off topic, I am about to lay down some hexagon grip tape on my board. What process do you use to keep everything so even?

1 Like

Damn, I had all my boards with the same issue, not eworking on the standsr HM10 module, however on my case I can’t even connect.

1 Like

Hey @Sender Sender, Although I have 10s Dual 6374 I also get a similar issue, for I’m running hybrid bldc and the solution that @lrdesigns suggested is what worked for me. Now with foc, I have no idea. Maybe @Deckoz @mmaner can chime in? They’re people i talk to fairly regularly and I know they use FOC. @JLabs is also good at diagnosing so maybe some VESC/BLDC tool screenshots might be good.


I plan on doing a bit of tweaking and honing to find my sweet spot. Those 2 guys are my biggest resources on here!

Are you running Ack?

1 Like

Yeah, I figured if it didn’t work, I wouldnt even be able to see the module.

I can connect just no values for telemetry. Funny thing is when I first connected I was getting my voltage. Then, the next day I could connect but not see any telemetry.

I couldn’t take it anymore so I zipped it up and went riding. I want to believe I will sort it tonight… but the temptation to just go ride is so real. I still need to find 3 hours to elegantly lay that grip tape…

I wish I knew, all of my FOC boards do that. Ive just gotten used to it, dont even think about it anymore. Its just before full stop.


Yup, the full brake when going slow happens to me too. I’m running dual 6374s in Ackmaniac’s FOC.

I did used to run FOC on dual Hummie hubs using 2.18, and I do not recall having this issue if that helps people pinpoint a potential solution.


Hmm thays weird that sounds very similar to the braking problem I have with my Raptor 2, once they fix my BMS problem (board wont turn off) I’ll try out the board in BLDC and see if the problem persist.