Starting Tips | Ask Questions | Introductions | Categories

Which bldc tool for linux new enertion vescs

So, now I have everything in place, and when I click on the links to Vedder’s downloads it all looks Japanese to me, I do not know what the hell to click on… Can someone help please :slight_smile:

1 Like

Try Jacob’s site. It’s a little more intuitive. If you don’t want to deal with terminal in ubuntu, go that route

so damn confusing… So I downloaded bldc onto another laptop because I have linux on mine, and I plug the vesc in, and I got nothing…

I would like to try on Linux. Can anybody help me download the right bldc tool?

just clone the github repo and compile it

Ok, cool, now I have the BLDC tool on my screen, I turned on the Vesc, plugged it in to the computer, and nothing… It is like the computer does not even see the vesc…

The only mini usb I have at the moment is the charging cable for the Enertion controller, I wonder if this is a power only cable?

that may be the case.
i would buy one to be sure.

Not all OS’s have the driver for VESC’s usb device; you may need to install it.

Now I am back to linux…how do I install drivers??

Tried a different cable, when I plug it into the computer nothing happens, can anyone help?

What are you using to power the VESC while the cable is plugged in?

space cell…

voltage could be too high or something?

should I cut my laptop power cord and splice it to power the Vescs? 19.5v it looks like

I don’t think so. Are there any lights on on your vesc?

somehow I got it to connect, I do not know what I did… I just tried it again, and it worked…

It was probably your linux that needed a virtual COM port to be configured (driver install)