Bad motor detection help

So just a preface, I’m new to all of this so if there is any extra info you need please ask and i’ll try and provide it. The parts for my board are all bought from motor: 6365 190kv sensored vesc: maytech vesc firmware 3.40 hardware 4.10 battery: 10s2p

So the problem is, I’ve been riding the board for a few weeks and on a ride the motor suddenly stopped spinning and wouldn’t respond to the remote. Once it was home and there was no load on it, the motor would sort of stutter. Then I went into the VESC tool and tried to use that to spin the motor, it spins properly but then says bad detection results, detection failed. I’ve looked across the forums but nothing I’ve found so far has worked. Hoping someone can help with this. If i’ve missed something out please let me know.

I would check my sensor wires. Maybe one of the wires broke, maybe one pin in the jst got lose etc etc. Do you use an extension cable? Like from the 1.5mm jst to the 2mm jst.

1 Like

Plug the controller into your computer and see if it throws any faults through the vesc tool. I’m aiming you have already checked all of the connections etc

If the tool doesn’t show any faults type “faults” into the terminal and see what it says. If it says there are no faults from startup try turning the motor manually and see if it spins normally or it’s giving you resistance.

1 Like

Try increasing the duty

1 Like

It will show if he has a drv error if he checks. He can also run motor detection and see if it errors too…

I’ve also had issue when using sensored bldc on enertion hubs but did sensored foc without a hitch

So mabye try different settings?

Hmmm maybe he just needs to try running the board in sensorless mode to see if it works…

That’s a good idea to make sure it’s only an issue with the sensors or the wiring.

I assume I need a multimeter or something else to check the wires for this? There’s no visible damage on the sensor pins, although the VESC end was compressed to fit in the case so I could see one of them becoming damaged over time. I’ll get something to check the wires and check back on this one

It doesn’t throw out any errors, even typing ‘faults’ into terminal it says no faults. It’s just the bad detection message

Just tried it in sensorless mode, it doesn’t even spin, just stutters a few times and a red led flashes on the VESC

also got these faults now:

Fault : FAULT_CODE_ABS_OVER_CURRENT Current : 67.9 Current filtered : 130.1 Voltage : 38.63 Duty : 0.081 RPM : 74.7 Tacho : 8745 Cycles running : 3592 TIM duty : 2265 TIM val samp : 1132 TIM current samp : 15165 TIM top : 28065 Comm step : 1 Temperature : 27.31

Fault : FAULT_CODE_ABS_OVER_CURRENT Current : 49.7 Current filtered : 131.7 Voltage : 39.19 Duty : 0.077 RPM : 54.0 Tacho : 8814 Cycles running : 3288 TIM duty : 2214 TIM val samp : 1107 TIM current samp : 15456 TIM top : 28698 Comm step : 4 Temperature : 27.75

Check your phase wires, solder joins. Make sure the capacitors are fixed properly on the vesc etc. Likely that the fault comes from a lose or bad connection.


I was getting the same results when I first hooked my motor to vesc. It was because I tried to hook one of the motor wires to vesc wire with an aluminium clamp deal and not enough current would reach the motor. Motor would stutter and vesc would flash red. Problem stopped once I connected the wires correctly

Just checking here. Are you motor settings equal to or less than 25/-25 amps respectively? Most of these Chinese vesc copies can’t support more than that. Also can be due to high resistance or a bad connection as above. Try switching motors and speed controllers around and seeing if that has any affect.

If your using a dischatge bms check that you didn’t create a ground loop. I had a bms that had multiple shunts to connect battery wires. 4 on each side, I connected the battery - to all 4 shunts, when I would use the breaks I would get abs over current. I also got over current from a bad series connection once. Good luck.

I hate to be the bearer of doom and gloom but if that motor was defective then re doing the detect will have damaged the vesc. Always check the motor first before hooking it back up to the vesc tool.

checked wires today, everything seemed fine is there anything else I could try?

I’m not sure, how would I go about checking that?