Battery only charging to 64%

Like the title says it charges to 64% but then stops and the green light on the charger turns on, I’ve tried to leave it to see if it’s having an issue balancing but to no avail, I’ve also replaced the bms which didn’t help, anyone got any ideas? I’m skipping the discharge on the bms btw Charger


Is your battery gauge set to 12S instead of 10S?

What battery is it?

1 Like

Try using a multimeter to measure the actual voltage from the pack to see if’s really giving you 42V


Made sure it’s set to 10s, it a 10s4p Samsung 25r pack I got made from one of the members on the forum, did 2 full cycles on the battery then this happened

What are you measuring the voltage with?

What is the voltage actually coming out of the charger? I had a “6s” charger that should have been pushing 25 volts but it was rebranded and mislabeled and was only actually pushing 16.4 volts or so.

Using one of those 10s voltmeters But also using a voltmeter to measure the actual output and it’s only 38V

I’ll have a look now

It’s outputting 42V still

1 Like

I think you have a bad connection in the battery. If the charger worked before…

I’ll have a little look in there tomorrow, gunna need to get some replacement heat shrink

If one of the parallel connections is bad, the other batteries in the same parallel group wil reach 4,20v Long before the others, and proceed, because the total end voltage still is to low, and then the bms shuts down the charger because it’s protects the battery cells. This could maybe be your problem.


Thanks, I’ll have a look at each parallel group tomorrow and report back

So I’ve tested all of the parallel packs and one of the packs is giving literally 0 volts, I am so puzzled, there is a connection there as I checked with the ‘beep’ mode but there is nothing there :thinking: :confused:

How did you check and get zero volts? If it’s through the BMS balance wires then the balance wire may have come loose. This would explain why the main discharge wires are still giving you 42v.

It may be a simple case of re-soldering back the balance wire…


Each cell apart from those 4 are outputting 4.2V but those 4 are giving 0, checked with a voltmeter The charger is giving out 42V but the pack is not

So what voltage are you getting from the discharge wires of the pack?

38V 10 char

Did you measure that from the balance leads or directly on the cells.

If you measured at the balance leads a lead could be broken. If you measured the nickel at the cell the spot welds could be broken. If you measured at the cell and the cells are 0v you need to replace those cells.

My bet is on nickel or balance leads broken

I’m measuring it on the tracks, the connections are made though, just no voltage through them