BDUAV 6384 120kv / Flipsky FSEC 4.12 / 12v 20Ah SLA battery.. motor won't spin

I’m working on a project for a slow-moving “push” vehicle and have issues gettiing the motor to spin. I’ve using a FSESC 4.12 ESC, BDUAV 6384 120kv motor and a 12v 20Ah SLA battery.

For starters, the BDUAV motor has only 5 for a sensor wire. From some research, I found that it does not have a temp sensor, so I’ve changed the motor sensor wires to reflect the following: +5v(red) TMP (blank/no wire attached) H1(orange) H2(white) H3(yellow) and -(black).

From there, I ran the VESC Tool and attempted to set up the esc. I’m using a hobby grade Futaba T14 radio and FMR-02 receiver. I can connect to the esc successfully, choose the PPM input option (with the icon of a RC radio) and see the PPM mapping when I move the proper stick on the radio associated with that channel. For this application, I wish to use the esc as FWD-REV, as such I tried to use the PID speed control option. When I’m finished with setup, the motor will not spin, only a bit of a whine and what seems like an attempt to move in either direction.

I’ll add that I tried to do the SETUP Motors FOC, where I also set up the battery type and 3S with 20.0Ah but cannot complete as it gives an error that there is a connection missing when attempting to spin the motors.

Any help would be greatly appreciated,

1 Like

Try “Current” mode instead of PID Speed Control

Thank you very much. Will do and comment afterwards with results.

1 Like

Tried “current mode”, got slight movement and then stop. Not quite one motor rotation and then motor will not move afterwards. Cycled power on FSEC and same thing happens again.

Post screenshots of your screens:

Motor Settings > General > General
Motor Settings > General > Current
Motor Settings > FOC > General
App Settings > General
App Settings > PWM (“PPM”) > General
App Settings > PWM (“PPM”) > Mapping

Have you been able to do a successful motor detection in the welcome and wizards tab? I see BLDC tab so it doesn’t look like you have done a FOC motor detection, and that would explain why it won’t spin

I tried to do a as FOC but will not complete successfully

To be honest, I’ve never seen anyone use large motors with a 3s nor a 12v battery. You said something about FOC not working; have you tried sensorless set up on FOC? I don’t know what you meant by “missing connection”.

Silly me… I think I neglected to connect to the FSEC before doing the FOC motor detection. It has just been completed. Will try to proceed from here and report the results

1 Like

I recommend choosing medium outrunners. Glad you realized it needed to be plugged in.

Success!!! Thank you everyone!!! It now works as I want. Fwd-Rev with no brake. I’m super happy to finish this build.


You’re welcome.

The FSEC was indeed “plugged in” but I had not clicked the “connect” button to it prior to trying the FOC motor setup.

1 Like

Yeah, it happens. Enjoy your successful build.

Again, a sincere thank you for your help :grinning_face_with_smiling_eyes: