Bluetooth HM-10 not discoverable on Android 8.0/8.1 Oreo

The topic has made some developments in which it became clear that hm-10’s are not to be paired with like a Bluetooth speaker for instance due to the Bluetooth profile BLE. HOWEVER the question remains why I can’t find the module using an app like VESC Connect on my Nexus 5x running 8.0 and 8.1.

For ease of use/understanding, below is the original topic:

Hi there,

I am trying to connect my phone(s) to the HM-10 module on my board. The module is connected to the VESC and there is a red LED blinking, so far so good!

But trying to connect to it using my Nexus 5X running Android 8.1 (previously 8.0, but didn’t work either) is not possible since I can not find it at all…

Using my old Samsung S4 running 7.1.2 custom ROM LineageOS I am able to find the module but when trying to pair to it I get the message

Pairing rejected by BT05

Is there any setting I need to change? Maybe something on the VESC? My VESC setting for Controller ID is set to 2, maybe this needs to change?

Keywords: not connecting, bluetooth, HM-10, HM10

I have no clue how any of these things work, but maybe you can understand something from the following link? Could be the module?

1 Like

Thanks for this link! I should have searched BT05 myself… hehe

According to this article I have the CC41-A

Here is a comparison of the responses to “AT+NAME” with the default name set in the module:


+NAME=BT05 “MLT-BT05”:


Will have a better look at this article shortly, although it doesn’t seem to have a solution for this problem. Will google it shortly as well!

There’s no reason to pair the device.

Just open the app, the app will find it and connect.

The reason is the Bluetooth tx/RX pins aren’t sending normal Bluetooth data that the phone understands. Its sending UART over the air, the app is the other end of the UART connection.

Just forget the technicalities and open the app with your skateboard turned on and search for the Bluetooth device in the app.

Since I updated my Nexus 5X to Android 8, no more bluetooth connection with none of my BT modules ( included). I’m considering downgrading the phone to Android 7, so much troubles with 8.0. :confused:

Tried that but scanning with didn’t work Thanks for the insights though!

Damn that sucks… But using my Samsung S4 running 7.1.2 I can not find it when I scan with Metr app

Did you get it recently? If so, then look at the end of the Metr thread.

I got it somewhere in August but just finished my build. I didn’t get the module from @rpasichnyk, but from @fottaz. Could this be a problem?

I tried VESC Connect but I couldn’t find the module either.

Sorry, I don’t know. I thought you had to get a special module for Metr?

Its Just an hm 10 man, the same as what he’s using.

I dont know where you saw the baud rate since you have never been to the UART Tab of bldc. First of all, go to the UART Tab and see what baud rate is setted up.

I thought as well, but @fottaz says on his website that it’s possible…

Hi @fottaz I had seen that tab, but I thought you meant another page. Couldn’t remember there was an individual page for UART hehe

Lol ok dont worry! At this point I would suggest you to try flashing Ackmaniac and installing his app, I’ve never had any pairing issue with It! Tomorrow I’ll try with metr and my current Android version and let you know! Stupid question, isnt your phone with hidden bluetooth right :)?

Okay I managed to pair with the board BUT only with my old Samsung S4 running Android 7.1.2 and using Jacob’s VESC app ‘VESC Connect’. Scanning for the module inside the app instead of the phones bluetooth settings

Not desirable but it works. The battery on my S4 is terrible :joy:

@fottaz Looking forward to your findings! :slight_smile:
Flashing ackmaniac’s firmware requires a bootloader and thus some wire thingy to accomplish, right? My phone is discoverable, but that shouldn’t make a difference since the search happens from my phone not the other way around

1 Like

noo[quote=“GunnarK, post:14, topic:36713”] Flashing ackmaniac’s firmware requires a bootloader and thus some wire thingy to accomplish, right [/quote]

nope. pretty sure theres a guide on here on getting a bootloader through VESC-Tool ill put it up here if I can find it

EDIT: found it -


try connecting it to the ackmaniac bldc tool, if bootloader is installed (90% of maytech have it installed), the software will tell you if it’s possible and will suggest to upgrade it.

1 Like

Cool will try immediately!


remember Buad Rate to 9600 for that

1 Like

So far so good, but the firmware is a little bit tricky. I went to the firmware tab and browsed to my downloads folder where the ‘’ and unpacked folder are located. What file do I have to select? I can not select the complete zipfile

I assume one of the following? VESC is version 4.12, installed firmware is 2.18

EDIT: read on this thread that I need one file from ackmaniac’s dropbox: VESC_Ackmaniac_Mod_2_54.bin. Will have a look at this firmware later

Did you buy a module?

If I’m not mistaken the developer has programmed the Bluetooth Mac addresses into his app. So you’ll need to purchase a module from him

If you purchased from him, modules before a couple months ago ran 115200 baud, the new ones are 9600 baud I believe.

@rpasichnyk Hey Roman maybe you can help if he did purchase from you…

1 Like