Bluetooth HM-10 not discoverable on Android 8.0/8.1 Oreo

Hi I did not buy the module from Roman.

I’ve read that Roman programmed his modules or something so they work with his Metr app. But the things that I read about it on his forum were from some time ago. And there were all sorts of discussions about licensing so I thought (since fottaz’s website says it works with his modules too) he had made his app public and is earning some money through donations by now…

Looks like that’s not the case

Fottaz is looking into it so we’ll see! :ok_hand::grin:

If you bought a module that wasn’t from Roman. It won’t work… No amount of looking into it is gonna change that. As you can’t add the mac address of your module into the software(

1 Like

I understand. But that is if your story about MAC addresses is correct. I will not be making any decisions on what is correct for now and wait till fottaz has an explanation.

You can wait for fotaz all you want. He didn’t develop, Roman did.

I own two metre modules, and have tried doing simple renames of extra hm10 i haveBluetooth devices with “AT” serial commands to set the Bluetooth device name to match his “metr-XXX” naming. It won’t do anything even with the same name as another module. The only other option on these HM10s is to pull the Mac address off and use that to lock down connectivity within the application if you dont want people using an app without your module.

If you dont believe me, hook up your hm10 to a FTDI adapter, open the serial console in arduino IDE @ the baud rate of the module, run the AT commands to set the name, AT to set baurdrate (115200) and AT save.

Try all you want, you won’t get anywhere unless you can rewrite the Mac addresses

As well if you look at on google play you can see the version revision history. Roman publishes a new version almost daily. Anytime a new module is sold a new version is released to accommodate additional mac addresses. You really think he updates the software daily with bug fixes? Doubtful.

You won’t be connecting to the Metr app unless you purchased a module from the creator. He states this very clearly in his thread. Use @Ackmaniac firmware/app if you’d like to use your bluetooth module to change/monitor your vesc’s.

"Full disclosure:

I’ve spent a lot of time and energy designing and implementing the apps including the web part. I’ve thought carefully about the business model and how to make the apps future-proof​:moneybag:. I decided to make the apps free and earn money by selling the bluetooth modules. Thats why I’ve built some protection that only allows apps to work with my modules. Other modules most likely won’t work. This also helps me to provide best user experience and ease of use. The modules I sell are no soldering required™ pre-configured© plug and play® solution."

Guys take it easy. I fully understand what you are saying. I study computer science including hardware engineering so I know a few things about AVR/Atmegas and Arduino to say the least I talked to fottaz and want to give him the opportunity to sort things out. That’s all

I have read the full disclosure a few days ago but already had bought the module from fottaz while he stated it should work with Metr. I didn’t know at that time it was Mac address specific

I doubt that just as much

A bigger issue is WHY am I not able to connect to the HM-10 in any way using my Nexus 5X running Android 8.1/8.0?

@Pimousse is having the same problem so it seems to be OS related, but why? And is there a workaround preferably one without the need of root access

Hm10s by default are non discoverable/pairing BLE UART over air.

They aren’t designed to be “paired” with. And shouldn’t show up in androids Bluetooth pairings. Older phones with pre bluetooth v4+ the BLE devices would show up. But BLE devices are not designed to show up in the Bluetooth pairings of android.

1 Like

Alright so it seems. Thanks for confirming that I will look into Android 8 vs BLE and report back here. Or do you have any insights into this issue, @Deckoz?

I have created a topic on the Google support forum. Could become very handy I hope!!category-topic/nexus/connecting-to-networks-and-devices/nexus-5x/QxcbWBsnvWc

Indeed this is normal the HM10 low power bluetooth device. Any app designed for low powered bluetooth devices will see it and connect for you.

My Sony Z5 sees is but wouldnt pair, which left me scratching my head for a while. Opened up ACKMANIAC-ESC Monitor and bam, it found and connected to it instantly.

Im using 7.1.1

1 Like

I have made some changes to the topic to be more aimed at the problem (Android 8 vs HM-10) since it has become clear that BLE devices aren’t supposed to show up in your phones Bluetooth settings.

Thanks for double-confirming this @danielz!

It seems that Google is working on a fix for bluetooth, but mostly focused on BT headphones issues. Same for Wifi, I have so many trouble with it, consuming a lot more of mobile data (issue also known by Google). Do the 8.1 update correct some of these issues ? My phone sticks to 8.0 and says that I’m up to date…

I can confirm the OnePlus 3T on 8.0.0 does not work, 7.x.x was fine. Will update if anything changes

1 Like

Didn’t read the whole thread tbh and don’t know of this is relevant for you, but for me the ackmaniac app doesn’t find the hm 10 unless both BT and GPS is turned on on my sony xperia.

1 Like

Hi @Pimousse AFAIK I don’t have any issues with Wifi, but I cant say anything about Bluetooth since I don’t own bluetooth headphones. Here is a screenshot from my data usage this month running on Android 8.1. I have a data limit of 5GB

Measured with the app Data Usage Monitor (non root)

In my opinion Android 8.1 runs flawlessly and much faster. Gives this feeling I got a brand new phone. I definitely recommend. You do have to sign up for the beta program, but that is fairly easy these days. Just register your phone here, thats all Okay it’s beta software but as long as I’m using it I haven’t got into any problems. Downgrading is as easy as unregistering your device on the same page

@scepterr once I find out it works with a upcoming update I will let you know in this topic :wink:

@Sebike this wasn’t discussed before so good to know !

Has anyone tried the official 8.1.0 update which was launched a few days ago to see if BLE is fixed? Can’t find any answers with my quick Google search

@GunnarK i dont have this module, but i use a bt05-a module for other apps. I can confirm STILL BROKEN in 8.1

@trancer23 what device do you have? Apparently the official 8.1 is only available to pixel 2 (XL) and Nexus 6p

I have a pixel 2 (not xl) on verizon. I was on the developer beta build, and got a notice to update to the official.

My build is Android 8.1.0 Security Patch level: December 5, 2017

1 Like