Bluetooth HM-10 not discoverable on Android 8.0/8.1 Oreo

Just got an update on my OnePlus 3T, still 8.0.0 but Bluetooth WORKS! :smiley::smiley::smiley:

1 Like

New Pixel owner also looking for answers on this. Any Pixel owners managed to get it working?

Download some ble check app to see if your phone has ble

Just download ackmaniacs app and it should connect without pairing

Its BLE usually not visible in bluetooth options as I know

I have a 1st gen pixel and its always worked. I have an upgrade to the Pixel 2 sitting here on my desk, just haven’t moved to it. Took it out of the box, did a rudimentary setup, connected to the @Ackmaniac VESC app, no problems. Both of my pixels are on Verizon, not sure if that matters or not, but any info helps I guess.

1 Like

What version of Android does it have?

@Acido that’s not the issue there’s a bug in Android 8 that breaks some BLE functionality

1 Like

The phone immediately requested an update as soon as I turned it on, its currently at 8.1 and works. I did not try it with the original load.

1 Like

So @mmaner you are running the official build. Not a beta?

I currently running 8.1 beta on Nexus 5x, it should receive a new patch in a few days if I’m correct. Hopefully there’s a fix in that, otherwise I might revert back to 8.1 official

@Acido that is not the issue. Nonetheless worth mentioning. I didn’t know this in the first place either…!

Official, i don’t typically root anymore, too much time involved :slight_smile:

Yeah the app says it detects a low power BT but always fails to connect.

Hmm…how frustrating. Maybe it’s an XL 2 issue. The app says it finds it, but cannot connect. Wait, I don’t need to unpair it from my old phone do I?

I don’t know, it’s worth a try.

1 Like

You don’t need root to run beta software for Google Beta Program. You can sign up your Google phone at

Don’t know either.

I am not even able to find the module with my Nexus 5X running 8.1 beta with November patch

Nothing at all? My finds it (or maybe another BLE device around my apartment) but then says fails to connect. How frustrating. Glad I didn’t trade in the old phone just yet.

Nope nothing… Sounds like that’s less of an annoyance than being able to find it but unable to connect :sweat_smile:

Same here, updated to oreo, suddenly no chance of finding Module… worked perfectly before :frowning:

Is not fixable by App. It’s a problem with the firmware of the bluetooth module (HM10) and the stronger bluetooth error tolerance in Android 8.x (OREO).

So a new FW for the bluetooth module is needed, it’s buggy.

See this link for more information:

Or search for “hm-10 oreo TI android bluetooth” in your prefered search engine.

The used bluetooth module is called HM-10, which includes a chip (CC2541) from TI (Texas Instruments).


We need more ppl on this issue

EDIT: Already found an important note from android which the DEVs could look in to

Android 8 includes changes that bring both good and bad news. The bad news is that the existing workarounds will no longer work to let you detect beacons when you app is not in the foreground. The good news is that new APIs give you new ways of doing these same detections,


Would different bluetooth module help?