Brakes failing don’t know why please help

Today I was riding down hill tried braking and my brakes only produced a tiny amount of brake force.

Had to bail board out and jumped off luckily I was only going 15mph board got smashed a bit.image Only new thing we’re some new motors

but this is a pretty new build however so I don’t know for it was setup correctly

My build is tb 260kv 6355 motors 10s2p Samsung battery produces 20amps Flipsky dual 4.12 vesc Abec11 flywheels Gt2b remote

Please help me probably didn’t setup bldc tool correctly please help thank you

what are your vesc settings?

You might be going over the erpm Limit

New motors that are high KV – probably means that if you didn’t change your VESC settings then the previous motor min values are now producing too little breaking torque. Either that, or your BMS tripped and wouldn’t accept the return voltage. Definitely share your Vesc settings.

1 Like

What should Erpm limit be

Don’t really understand vesc values so probably have made so many mistakes

1 Like

Here are picturesimage image image image image

1 Like

I know that I probably made some big errors main one Is with the throttle and brake curve I think I got that one wrong

Were you close to a full charge? Brakes will fail with a smaller battery at or near full capacity. The vesc has no where to dump the extra energy so it jusy wont brake.

1 Like

Probably around 90% charged


Is that the only reason

Found your problem

Should be imo try doing the same thing in a safer manner if you can but with 50% charge and no other changes i bet it will brake perfect.

I tried braking before with board upside down on half charge however I could feel how easy it was to turn the wheel

Ive had this happen to me on a 10s3p with 97% battery it was quite the scare. I believe someone makes a product now to fix this problem with smaller batteries.

Are you sure that is the only reason still dead scared about it

Is there any problem with settings

They look good to me, but I’m no expert.

You said your battery could do 20 amps total or per motor? I see you have it set as 30 per motor for a total of 60. What configuration and cells does it use? lipo/liion?

1 Like

Your “absolute maximum current” is set to only 30A, I would suggest resetting it to the default value which is a bit above 100A if I recall. A sudden current spike from breaking could have easily passed that.

Also, I noticed that you have dual VESCs over canbus (I assume that’s how the Flipsky dual works since it has 2 usb ports). Make sure you have the same motor settings for both, and also this means your battery current limits are too high! Assuming your battery is from Samsung 30Q cells (which are good for 20A per cell), your battery limit should be 20A per VESC, and charging (“battery current max” aka regenerative breaking) limit should be like 10A per VESC. (Which is still 2.5x higher than rated for the cells, but hey you have a small battery and breaking is important, just try to be easy on it to preserve longevity of the battery)

I wonder if it really was the BMS or something that cut off as you were trying to put too much amps into it.

Yeah you do have quite an interesting throttle curve :smiley: Maybe just set it to linear for the moment to keep things simple while testing :upside_down_face:

1 Like

Lion I think it can do 20 per motor I have it set at 30 because I am not exactly sure about the amount