Did I just fry my Raptor?

I’ve been the proud owner of a dual Raptor for about four months. I’ve had no issues with it…until about a week ago, then began a sequence of events that has me fearing its fried. To best explain let me start with a quick chronology:

1.) June 26th - board randomly shuts down while riding over rough surface. Turn off/on, board fires back up, no issues rest of day. 2.) June 27th - while riding the board shuts down and won’t turn back on. Power switch on space cell is very loose. Upon further investigation, it appears the battery shifted which jammed the power switch against the opening in enclosure lid causing it loosen and fail. 3.) June 30th - thinking this would be a relatively easy fix, I order new power switch (this one http://www.ebay.com/itm/5Pcs-2-Pin-On-Off-SPST-Round-Rocker-Switch-AC-10A-125V-6A-250V-Black-/262209348826?_trksid=p2141725.m3641.l6368 ) and remove old switch and solder (I suck at soldering) in the new one. The new switch is virtually identical to old, but the prongs are a bit longer. I snip the prongs shorter so it lays flush on space cell like the old switch. Switch works, board powers up and seems fine. Only difference is the lcd screen blinks once when switched on. Test ride around block is good to go, no issues. 4.) July 3rd - A) riding board to breakfast, take off from stoplight with a kick push then throttle like normal, accelerate to about 15mph and suddenly the brakes (or brake) slams on, I do a poor superman imitation and earn some minor road rash. Get up, look at the board, it’s off and won’t turn back on. One motor seems to have heavy resistance (attached to slave VESC) while the other has normal rolling resistance. B) Walk home, pull space cell out and disconnect from board, turn on and it powers up like normal, plug back into board and it shuts off. Happens multiple times. Plug fast charger into space cell while battery is connected to board and get a decent size spark. C) decide to try different battery. Plug in @torqueboards 12s battery (used with board before without problem) get a fairly big spark at xt60 connectors. D) pulled new space cell switch. Soldering is ugly, but seems solid. decide to seek help before I melt my board. My questions: Am I correct to assume there is a short somewhere in board and not battery? Could poor soldering in power switch to battery lead to a short in board? Are my VESCs likely fried? Would a short in one of the motors cause this? Greatly appreciate any feedback.

Ugh - suck man. have you contacted @carl.1 to see steps they suggest? They build it, they can help. Might be worth taking some pics to show them.

Best of luck!!

The spark is indicative of a short, while the behavior sounds like a faulty BMS. I’d do as @sl33py suggested and email Enertion Support.

not yet. I’ll load some pics when I get home tonight.

i would test VESC and motors directly - eliminate all variables.

edit - spark. Depending how big, that may be normal. When connecting 12s without an anti spark connector they can give off quite a big spark. Now if it’s melting/slagging the connector that sounds like a short… I’m not sure, but i thought the SPACE cell had anti-spark built in?

Take your known good DIYes 12s battery - a single VESC, and a single motor. Can you get it to work on the bench?

Swap motors and VESC’s to see if any VESC or motor doesn’t work correctly. Since the SPACE cell was your culprit i’d set it aside until enertion replies and you show pics to troubleshoot.

But i’d also be worried of damaging VESC and motors. If a motor acts oddly on both VESC’s it might be bad, but i’d also connect up BLDC tool and look for errors on VESC. Hopefully something simple if there is an issue - something like swapping the DRV chip which is doable (not for you if you suck an soldering) vs just simply fried.

Will be following and fingers crossed it’s an easy fix man!

Really appreciate the feedback. I’m gong to try the BLDC tool and take some pics tonight.

when you disconnect the battery, did you check spin resistance of the motors again. Because if the phase wires are shorted inside or outside the motor, then it will seem like the brakes are on. I mean you can unplug the motor and touch 2 of the phase wires together and it will cause resistance like the brakes are on. So if you have brakes when the motor is disconnect, then you have a motor short. If the brake releases when you unplug from the esc then you may have a short in the esc. I experienced a similar situation once when I fried one of my esc’s

You said the battery worked fine when it was disconnected from the Vesc’s so I’m guessing your problem is not the switch or the battery but either the Vesc or motor or wiring in-between.

Yes, do the steps mentioned above, it’s what I did when I had motor trouble with my dual ( space cell was fine though).

The first gen motors don’t have isolation running up to the point where they enter the coils. Riding rough surface gives vibrations and in my case stranded wires came loose and caused a short in one of my motors.

Take a look in this thread how I fixed the motor problem. I got a new motor in warranty from enertion which I will swap later when I get home again.

Good luck! Let us know what you found, it’s handy for the knowledge base.

I definitely still have resistance with the battery disconnected, but I think you’re saying I need to disconnect the motor from the vesc and then check for resistance…is that right?

yes, disconnect the motor in question form everything and then try spinning it. It the brakes are still on then you have a short in the motor

If the motor spins normally by itself but has more resistance when you connect it to the vesc, then you likely have a short on the vesc

Basically, touching 2 of the 3 motor wires together will cause brakes or resistance

When it happen to me, it was the Esc. shorted out and burned up. the motor was fine but dragging as long as it was plugged into the esc

Thank you. Exactly the feedback I’m looking for.

I’m hoping it’s not ur esc. Pushing the wires more inside the motor if it would block still while disconnected can also resolve the short. Then ur sure its inside the motor.

I always go simple first. Before the spark, I was thinking the reason was a loose connection between motor and vesc. Try and check there is proper connection at the vesc point. Possible loose solder. Youll need to get the hot glue off to check.

Now that there is the spark something else may have been damaged. Need to break down the potential reason by elimination. I think its back to Enertion support for help. Ive got a dual here you could use by Im in AUS. Hope it gets fixed first.

On another note with the toggle type switches now being used for the battery is there any chance that you can turn it off when riding. That would not be good. Glad you didnt experience too much pain on that sudden brake to the shop.

Quick update. Tried connecting to BLDC without success. Went ahead and removed the slave vesc side motor, no visible shorts. Plugged in space cell and turned it on…spark followed by small fire on slave vesc…good times. Pic attached. Pulled slave vesc and plugged in space cell…board fires up. So looks like master vesc and motor is good to go. Next step, get on list for a vesc.

1 Like

i would try and find out what happened before hooking up another fresh VESC. Check the bottom side of the pcb and see if the jst pins have punctured the positve primary power cable. Pick and place manufacturers rarely, if ever, trim these and they will eventualy puncture cables if left long. I circled the GND pin in question.


This knowledge is why I buy all my VESCs from Chaka.