Dual VESC CAN Problems


for two days i was riding perfect in dual Motor setup with my new Focboxes. after ride without problems i charged the battery, plugged back in and just the master was spinning.

i did not change anything in bldc inbetween.

did a firmware update and made dual settings again. Master > ID-0, send over can-no,multiple escs over can-yes Slave > ID-1, send over can-yes,multiple escs over can-no PPM with UART, and can cable plugged in

still not working ?

any ideas whats the Problem ? as solution right now i drive with PPM-Y-cable buts not at all as smooth like over CAN.

greets and thanks Notger

1 Like

Check your connections and cables. They’re particularly sensitive and can get knocked slightly loose or frayed. This is why i stopped using CAN. What do you mean Y cable is not as smooth? It’s essentially the same for me unless you lose traction.

in can both motors were spinning pretty similar. with y-cable i see some offset spinning starts of both motors on the bench without load. the motos also stutter abit more on hill-start compared to can

Sounds like a setting somewhere else for split then. There should be no difference in performance on the two control methods if you set it up correctly for each. Slightly varying trigger points for PPM signal is a non-issue as well as it affects nothing for when you actually ride it.

Make sure you turn off “send status over can” when using split ppm.

1 Like

went trough all the settings again, you were right, i had to make autodetect on one Motor again. Now they work quite smooth while riding, still behave strange on teh bench.

Still: id like to know if anyone has an solution to the “broken-CAN-issue”. I do not need traction control, but id like to have the option of using the PPM on the second VESC for cruise control (with @Ackmaniac 's BLDC-Tool) and logging via bluetooth does not allow to see the data of the second VESC if not connecte via CAN.

So ? any other ideas whats wrong

? hmm did a whole Firmware flash and setting up both Focboxes up individually, still no CAN communication between both of them ? with ppm-split they work fine ? ideas

Usually its lights out when the tranceiver goes. Replacing it is easier than a drv but still requires some skill.

Sometimes it would only partially blow and lights would stay on. Have you checked for faults and tried a new can cable?

ähm, sorry, but what lights should be out, I’m not aware if the CAN drv would have seperate leds.

so my Dual Setup just works perfect in servo-split now, but just sponaniously stopped working when i initially used CAN.

BLDC-tool or Ackmaniac-tool do not show any faults, and yes i tried several CAN-cables and checked the solderpoints of the CAN Connector on he Focbox.

One strange effect i have is if i check “forward CAN” in one of the Tools, the VESC starts randomly disonnect its USB connection, after reconnecting it in exmpl, Ackmaniac-Tool and unchecking “forward CAN” connection is stable again.

Is there some " How-to Tutorial " about changing the CAN transceiver somewhere ?

Umm not specific to the can tranceiver but you can search board level soldering or reflowing on youtube then use what u learn to change it. Its U401 on the PCB I belive.

By lights out I mean no lights or response what so ever. Not always though, you issue sounds like it could be related to the CAN tranceiver but Im not an expert in diagnosing them.

If you can identify the CAN teanceiver touch it to see if its hot while the vesc is powered up. When mine failed the tranceiver was always hot compared to a a working vesc.