Enertion Nano-X binding issue (resolved)

Hi guys,

I got my Nano-X weeks ago but could not ride my board due to lack of wheels. I did some try testing on the bench and it worked brilliant. Now, 4 weeks later with no further action in between the remote does not bind anymore! The green LED (TX) and red LED (RX) are flashing continuously.

When I move the cable from channel 1 to Bind on the receiver, the remote binds immediately. Going back to channel 1 same story as before.

So, while doing tests I was shaking the receiver a bit and bending the cable back and forth and boom, the remote connects again. Not shaking the cable/receiver and the damn thing flashes forever. So, I really think that something is messed up with the receiver. Maybe some cold solder joints, partially loose cables, etc… I have not opened the receiver yet but I will do so this afternoon and let you guys know what’s going on.

Edit: Inside the Rx is just a solid PCB. However, I have to bend the connector attached to the pins to get the remote to bind. Doing this on my old GT2E all works fine without any issues … hmm

Edit2: When I move the connector up/down the pins on the receiver it connects immediately (max 3-5s). And once it is connected I can move the connector up/down shake the hell out of it, bend it back and forth and the binding is still remains active … wtf???


1 Like

Sounds to me like the receiver is the problem. I hope they send out new ones quickly if that’s the case!

Please send pictures of the receiver

I have problems too - I have to remove my receiver from the enclosure each time to get it to bind. Even with the remote right against the enclosure it doesn’t bind, Once it does though - it’s great. Have taken to carrying tools with me to open the enclosure and close it again. Once it’s bound it’s solid.

Hmm, it’s a bit more strange than I thought. Definitely not the transmitter. My wires are soldered to the VESC, however, moving the cable just a tiny bit (tiniest bit) and the thing binds. Not moving the cable at all nothing binds. In order to rule the RX out I have to change the cable.

But anyway, why the heck has the GT2E no issues at all (binds in less than 2s) and the Nano-X is flashing forever??? Ahhh …

Here is a picture of the PCB inside the RX housing.

Is it just the pic or does that pin look burnt?

Could you also post a picture of the other side of the receiver where the headers are soldered? I assume they are through hole, but I could be wrong

C2 and C4 are missing parts, not sure if it’s supposed to be like that though

Here are three more pictures. The marked pin is not burned. All soldered pins look solid.

Oh ok, it was just the photo then. Not the best soldering job on some of those through hole pins.

But it looks solid to me. It’s getting even weirder now. When I touch the cable with my bare hands it binds immediately. However, when I use a plastic clamp instead I can bend twist do whatever you can imagine and nothing happens. Only binds when I touch the cable with my hands???

Something’s definitely up with these. Has it got a ferrite ring on it? It must not be making contact properly somewhere.

No ferrite ring installed + no contact to other parts … and it worked before.

Has there been any good experiences with this remote? I need some hope for my first eSk8 remote…

Hmmm. I honestly have no idea then dude, probably best if @onloop sorts this out

Honestly, get a GT2B and a 3d printed housing. The Nano-x looks great but apparently only works with lots of luck.

It’s too late… I got the space cell + remote deal a while ago and I am still waiting on it… I hope by the time I get it this whole thing is resolved.

I haven’t had any trouble, been running it for a few days now.

Here is a short video showing my issues. Enertion support has yet to respond regarding a refund or replacement.


Looks like they are on holiday till the 14th for the most part. I contacted them and they just took my email down on a list and said they’ll get back to me. Good thing I can’t ride my board in this snow right now anyway or I’d be super mad about it. To much hype for a remote that can’t even live up to my gt2b.