Hi there. I’ve been having a problem with my board when I am accelerating or braking the motor cuts off which is somewhat scary. Apparently I am getting a FAULT_CODE_ABS_OVER_CURRENT error. My setup is: Sk3 6364 8s lipo Vesc-x
83mm wheels 15t/36t

Can anyone see anything wrong with my settings or setup? Or any other troubleshooting?

Your settings seem ok, personnaly i would put motor max 60A and batt max 30A. But that is just some tweaks.

What situation are you getting this fault?

If on the bench, no load and jamming the trigger full speed, up your motor max to 70-80A. Could also up your abs max to 150A…

If your getting this from a dead stop and jamming the trigger, maybe you should consider going dual 6355 or give yourself a kick start

Various situations. Some times when accelerating both from dead start and push start. Sometimes when cruising along the brakes won’t work or the accelerate will brake instead of accelerate.

When on the bench applying full acceleration most of the times the motor stutters and continues to stutter until I take off the acceleration.

Well, at 8S i would crank up the abs max to 150-160A…

Would you suggest this to a dual 6355 build as well? I’m having the same issue once in a while

I tried this unfortunately it did not solve this :confused: thanks for the suggestion

I’m trying to avoid switching to dual motor because of the cost :confused:

If you can do a single, you can do a double, just save a bit more, it is really worth it

1 Like

As a uni student it was hard enough to justify the original purchase, but I guess I’ll have to have a think about the future of my builds

Sound like a bad motor or remote… what remote do you use ?

Benchwheel remote. Would the remote give off an over current fault?

Did you run a motor detection or do you use the default parameters from the firmware. Be aware that you have to press the apply button after the motor detection.

I ran a motor detection then changed some of the motor settings to suit my build. Yeah I press write configuration to apply the settings. Also I’ve had this build since mid January and it has been working fine but then 2 months ago these problems started occuring.

You have to press the apply button below the motor detection button and then hit the write button. Because the values you have there are not coming from the normal process. You either typed them in manually or used the default parameters form your firmware. Maybe that stressed the motor over time and this can be the error now. Or maybe the VESC has issues or got stressed by the motor configuration. And the information that it worked once and now not anymore is very important. Because that proves that something broke. Sadly many people tell the important information after a lot of posts.

The first vesc set up I did @Luke set everything up and I assume he did it correctly and pressed apply. When would you have to do more motor detection’s? Like when you change the settings or just the first time?

Just press the buttons in this order and show a screenshot how the screen looks like afterwards.

And you have to do the detection only one time. Only when you have Hall sensors and you change the order of the phase wires then you have to do it again. But that isn’t the case for you.

So the BEMF coupling was a bit off. 720 before and now 900. Maybe that can kill the motor or the VESC over time. Don’t really thinks so but i also never tried wrong settings over a longer period. Just test if you still get the errors.

I still had errors after that. However I decided to change the remote rx wires that are connected to the vesc and I took it for a ride without any issues whatsoever. Which is strange as I changed them yesterday when I upgraded the aesthetics. Would these wires cause the fault in anyway?

maybe… if the ppm wire is badly connect it might send wrong command to the vesc.