HW6.4 based ESC - ESCape

Sorry that Im so late but can I ask what is the peak amps and how kuch the continuous? Thank you

as stewii’s ESCape is based on the open source hardware software VESC 6.4, it shares similar ampacity.

Try using “search” with terms like “vesc 6”

1 Like

I replied to your payment email but I didn’t get any response @stewii . Can I buy it without the alu housing? What would the amount be to transfer if so?

You can, just order as normal, on the comments say you don’t want housing, then on the final payment it is going to be £10 cheaper per ESC.

1 Like

Good. I sent the payment now for two units but I’ve never used TransferWise before. Do you send some kind of confirmation to oldies like me so I don’t miss the deadline if I did smt wrong.

Hi @stewii, With @Manu39, we’re trying to troubleshoot a serial communication issue. I made a PCB with an arduino and a LED gauge communicating through UART. Mine is working flawlessly with a VESC 6, FW3.37. I tested his gauge board with a VESC 4.12, no problem. However, with the ESCape, the communication is established only when he’s accelerating. In idle, the Tx LED of the Arduino blinks but not the Rx one. We checked parameters together, AFAIK everything is set up correctly. So I’m stucked.

Any throughts ? Thanks !

weird, bluetooth works fine though through uart. Can you DM with info about that arduino PCB?

This an Arduino nano communicating through uart (voltage divider on arduino Tx) abd display battery gauge on a WS2812 ring, plus button and luminosity sensor Arduino side. @Manu39 tried to supply the Arduino through VESC 5V and by an UBEC on the main battery.

I have similar problem with @rpasichnyk Perimetr app and bluetooth module. There is communication error and following message, possibly connected to @Pimousse case.

Vesc tool shows that software version is in fact 3.37.

Edit: I’m going to swap TX with RX and see if it helps. Edit 2: It didn’t

what blouetooth module are you using so I can order one I know is working for when mine gets here :smiley:

I just tried with to connect an arduino nano I got here and Rx blinks and all works normal. I can try to replicate what you trying to do if you tell me what arduino program you have there.

Can you take a pic of the connections on vesc and bluetooth module sides?

I have a HM-10 and a NRF51822 both work perfectly.

Hi everything I want to know For the escape can I make 100000 erpm and can I go to 80a each motor Thank you

1 Like

@stewii, I have a pair of ESCape, I’ll test with them.

hello @stewii , as I said @Pimousse have the led fixed Rx: led lightly on…and the Tx LED is blinking. the Rx will start blinking when I’m zooming in and the Tx stops blinking. a pict of the connections the escape and the arduino

it’s the same thing on the slave and the master …

1 Like

Are the Arduino and the ESCape on common ground?

1 Like

Yes. The PCB is powered by the 5V and GND from the CANbus JST.

I dont use a voltage divider because most IO pins on the STM are 5V tolerant. Where can I get that PCB?

Well, I’ll tell @Manu39 to try bypassing the voltage divider.

That was only a small batch for french guys. I need to sort PCB design (like this one) issues before going further.

Are there any HW/SW differences between V6 and Escape that might cause Metr module to not recognize it’s proper software version? Cable connection seems to be ok. Module is visible in app but cannot establish communication due to allegedly unsupported SW version, this looks like communication is after all working properly but doesn’t get proper firmware information back.

1 Like

Strange with an HM-10 (aliexpress) and @emmaanuel eskate apps the module is recognized and connect immediately … i also ordered a module metr.at i will not fail to make a return on the problems or not… did you set baudrate on 115200 bps in VESC TOOLS?