Is my VESC fried?

I need some advise form you VESC experts. I followed all the instructions and end up with no motor detection and flashing red LED’s. I modified the battery settings before doing motor detection. I am using 2 XT90 anti-spark connectors in my harness. One at VESC connection and one in anti-spark loop switch. I thought that would make it safe for me to configure my VESC using fully charged 6S LIPO batteries (3 x 2S in series). I don’t have any additional motors etc. to swap out to get the answer to my problem. I can purchase a meter and check resistance in motor lead wires to try to eliminate the motor as the problem. I have a couple RC cars that have ESC’s but I don’t think I can connect my large E skate motor to one of those setups to see if the motor would run. As you can tell, I am not an electronics expert. Are there any settings I can change in the BLDC tool and re-try? Is they a way with a cheap multi-meter for me to verify if my VESC is toast? If it is DOA I just want to move on and buy another one. If so I want more advise. Do I buy a FOC Box with warranty and try again or do I buy a Olins VESC and try again? Or maybe a VESC from Miami Electric Boards? I need to hear from people with experience. Thanks in advance.

Are you doing the detection with the wheel on. If so that’s your problem you can’t test it with the wheel on.

Yes belt and wheel attached.

That’s your problem try it without the wheel and belt it should work then. Good luck

1 Like

Sweet! They don’t mention that in the Vid’s on VESC configuration!


Yeah don’t tell anyone but I made that mistake was rushing and wanted to get it done and forgot to do that. Also reset any changes you made to the setting well trying to figure it out don’t want and wildly incorrect values. By the way did it work

u can also increas ermp by 100s

1 Like

Glad you sorted it out. If you run motor detection without any motor attached and type faults in the console window, it should tell you if the DRV is bad or overcurrrent and things like that. It might be helpful for any future troubleshooting. Good luck with your build!

1 Like

I just tried to run motor detection again with belt/pulley/wheel removed and still get “failed Motor Detection”. When I connect the VESC to the BLDC tool it just flashes red but it does read configuration and I can change settings etc. Now I am back to square 1. I have to figure out if VESC is fried. If all I get are red flashing LED’s, does that mean I might be doing something wrong or does it mean the VESC is toast?

removing belt/pulley/wheel did not work. Where is the console window? Is that the box that gives you the values after it detects your motor? I want to try to do a motor detect with no motor attached and see if I can get fault codes.

I would recheck your values for anything you may have changed on accident or something you may have missed.

I still have not solved my VESC issues. Under sensorless I have “Min ERPM” and also “BR ERPM” and also “Phase advance at BR ERPM” Which setting are you referring to and how much should I change it to? Increase by 100?

ok I am driving blind but I managed to get some information. Please see screen shot and tell me what this means.

Double check your series voltage, make sure it’s in the 6S range (at the XT90 that connects to vesc), and well above the battery cutoff numbers.

Make sure your XT90S are fully seated.

Is the motor new (known to be good)?

Have you tried switching the phase wires around?

Does VESC smell burned?

Look at VESC closely with magnifying glass and see if you can spot any short circuits or burned/exploded parts.

When you do BLDC motor detection does the motor make crazy noises like it’s going to explode? (that’s normal)

1 Like

Your getting a OVER_TEMP_FET falt code take a look at this. The search tool is useful.

1 Like

Yow 108.30 Deg C it says.

Does vesc get hot? especially the 3 fat chips on both sides (the mosfets)? yeinats8j’s link is probably the best resource.

when you do detection, should see min erpm 600. up this 700 800 900 like that

Maybe firmware issue causing false over temp signal what firmware are you using?

1 Like

Maybe my old friend Dexter, @torqueboards can shed some light here. He helped me more than you can imagine when I was a newbie.

1 Like

motor is brand new Enertion Big boy. XT90’s are seated. don’t see or smell anything burn’t. Motor detect does nothing, no noise, no movement, nothing.