Landwheel L3-X hub motor problem

One of my hub motors stopped spinning. At first I had a problem where one of the motors needs to be in a certain position to “catch” and spin, once it got up to speed it was fine, and never noticeable as long as I kick-started my board. Now I can’t get it into gear at all. I can hear the motor spin up as I push the throttle and the hub “twitches”, but it’s not spinning, not even from a rolling start. if I try to step on the board and give it throttle the controller vibrates and blinks constantly and it’s obvious something is broken/loose inside the motor.

I have unplugged the motor from under the battery which lets me run single motor, which works okay, but of course I want dual hub motors. I plugged it back in the other day and got it working somewhat for about 15 minutes until it broke down again.

Any ideas what could cause this? and also any advice on getting the 13mm nut loose inside the hub cap? I got a skate tool with the landwheel which IS thin enough… But they decided to put a thick plastic cover around it which makes it impossible to reach, and I’m worried if I try to file that down the entire tool will break.

Here is what I have discovered since this post:

The working motor no longer works when I plug the cables from the wrong side of the ECU. However I can’t get the non working motor to spin regardless which part of the ECU it is connected to.

I also noticed the non working motor is “springy” if I turn it slightly it doesn’t lock into place, it springs back.

1 Like

I had one, could you send a video of it?

There is a thread dedicated to this drive. Search function is still up and running I believe.
FYI Please do some trying before creating new topics. Keep it clean. Try before you cry.

1 Like

I see your frustration and I apologize for any mistakes on my part, perhaps you are right that I should not have made a new thread, or I should have thought out my post better.

However, that said. I have looked through all major landwheel related threads prior to posting. I didn’t find an active thread about issues, and when I looked through topic “Esk8 Electronics” seemed the most relevant. I have looked through the thread you linked. However I didn’t think my question fit there as it is mostly for discussing the drive and giving tips and tricks and sharing news. It is a great thread though and I have spent a lot of time on there.

As for testing before I post, I have done a lot of testing. I just never tried cross-wiring the ECU, and I already knew it was “springy” prior to my OP, just forgot to include that part. I have already spent 2 weeks testing and tinkering with my board and hours on Esk8 before posting. Even gone to a hardware store multiple times to get the tools I need to disassemble.

And I have read on this forum that initially V4 shipped with a suitable tool, but found nothing about alternative tools I could use for a newer model, just one post about (possibly) being able to file a thicker one down, but no comment from someone who had tried and succeeded.

1 Like

I will send a video when I get home from work :slight_smile:
You had “one” what though?

I had the l3x and it was a blast but I sold it

Okay gotcha :slight_smile:

So, there are two things to try to fix this:

  1. Disconnect the sensor wires on the motor that is not functioning properly. Make sure you are disconnecting the correct sensor wires becasue they usually cross over. Left sensor on the ESC corresponds to right hub. If this fixes the problem then ride with one sensor wire connected and the other disconnected. You will not notice much difference in performance compared to original. The sensor wires assist with take off but they serve no purpose as soon as you have picked up speed. So one motor fucntioning on sensors is enough so that you don’t need to kick start from a stop. I see that you have tried swapping motor wires to opposite sides of the ESC. That was a good test. But if you are connecting the sensor wires when you swap then you are just moving the problem from one side of the board to the other. If the good motor works on either side of the ESC then you can be hopeful that diconnecting the sensor wire for the trouble motor may resolve your issue. If you have swapped sides then you have probably already found a way to remove the glue that holds the sensor wire connector together. Just in case, here is the easiest way. To disconnect the sensor wire you need to remove the yellow glue. I find that pinching the glue with the tip of a set of wire cuters works best. just grab two edges of the glue and squeeze paralell to the connector. Dont pinch or crush any part of the connector. Once you crush the glue a bit it will peel right off.

  2. The second possibility is a bad solder connection at one of the six motor wire connections. This is very unlikely if you have tried the good motor on both sides of the ESC and it works on both sides. Just in case here are the diagnostics to try. If the connection is still making contact then motor function could be intermittent. If its completely disconnected then the motor would vibrate in one position. To test for this fault, pull moderately hard on each connector while holding the wire an inch from the connector. Pull just hard enough to break the insulation, not hard enough to break copper wire. If the connector pulls away you had a bad solder connection. This fault was more likely on the V2’s. Far less likely on the L3-x & V4.

Based on your description, I’d say your problem conforms to the first solution, not the second solution.

Contact @revel_flo I didn’t have a hub key either and they sent me one no problem. Also they don’t charge much for repairs if you just send it in. They are a great company with awesome customer service.

1 Like

Thanks a lot :smiley: :fu: You were spot on with solution 1. the glue was so worn, I didn’t even need to grab my wire cutters, I could peel it off with my nail. Glue on the broken side was not fully covering, dust particles have coated the inside of the connector. I suspect it will work again after cleaning and applying new glue, will try that next. I noticed the worn connector before but was not brave enough to peel away the glue previous to your post.

You seem to know a lot, One quick question, been looking for the answer to this everywhere. Do you know what the different color-coded wires mean? disconnecting the blue wire seems to do nothing, but surely it has a purpose too?

Thanks for the reference, I messaged @revel_flo seems this time I don’t need to send in anything though :slight_smile: got it working with @pkasanda helping. Ended up being a bad connection on the sensor wire for the faulty motor. Once I got that fixed it is flawless again.

1 Like

I won’t be sending a video anymore, got it working w/ the help I got from this thread already. Ended up being a bad connection for one of the sensors. Got that sorted and it is mint again :smiley:


:ok_hand: Still though, if you can get your hands on a hub key I think it would be well worth it. I’d recommend checking and tightening hub motors every 50 miles or so, if possible.

1 Like

Orange | Blue | White | Green | Yellow | Black 5V | Thermostat | hall1 | hall2 | hall 3 | GND |

Many consider the blue thermostat wire to be optional, particularly when replacing the landwheel ESC wiht a VESC Example…Wireing patern to connect Landwheel hub motors to Maytech VESC image

1 Like

Oh cool, thanks. As a programmer I find VESC very intriguing, would be fun to tinker with. But that will have to wait a while.

But I was more referring to the 3 thick wires, ( green | blue | yellow )

Those are the PHASE wires

Celebrated a bit too soon :sweat_smile:

Yes, unplugging the sensor connector did make it “flawless” for a few seconds of testing. In the video you can hear what sounds like electrical “clicks” from the motor. This video is the last time I had it spin and not just twitch slightly.

I guess I need that hub key even more than I thought.

@pkasanda, @revel_flo @Kingdom421

Have you tried disconnecting both hall sensor connectors? I think you might have the wrong one disconnected.

1 Like

I did now, both are disconnected, same result :confused:

1 Like