Motor detection failed (Stutters) focbox

I also tried with the stock vesctool firmware. Same issue.

Oh and using the arrow keys on the keyboard to control motor works perfectly!

I have 2 focboxes and both has same issue and fails on motor detection.

1 Like


Are you using Ackmaniac FW and VESC tool?

Can you please try using Enertion’s FW and BLDC tool?

I tried the vesctool 3.37 FW and it was the same issue. I doubt its a FW issue?


I guess so, That’s why advised you to downgrade the FW to 2.18 and use Enertion’s BLDC tool.

There are plenty people here running vesctool/ack fw on focbox with no issue. But sure i can try downgrade and let you know if its any diffrence.

Ok one box is now ok when i raised the duty on detection to 0.1 Other box shows the same issue even when i raise the duty to 0.1

I had this issue as well. Try to increase duty cycle (D:) from 0,05 to 0,20.

1 Like

its so violent when rasing the duty… feels unsafe? no?

You want to complete motor detection or no? Sometimes you need to be violent and punish dat focbox. It’s raising duty time! Wear helmet for safety :+1:

Ofcourse i do but i dont want any POOFING this time :wink:

Found this on the forum:

I tried up to 0.12 but im afraid going higher since it becomes more violent as i increase the duty. Looking for some more input before i decide to go higher, i would be sad to blow a focbox before even testing it out :confused:

you wont belive me when i tell you the issue… I used a too long usb cable. Now it works



Oh I forgot about the USB voltage drop. Glad you solved it. Always use standard size USB cable or long USB cable with USB adapter or hub.

It’s due to voltage drop


What’s the perfect length? :slight_smile:

Standard size is 1.5 m approx Maximum length of the cable : 5 meters (with HI speed USB port 2.0)

1 Like

Ok I used 3M cable first. I still had to raise the duty to 0.1 to get a complete detection. Rode to work 6km and everything worked great!


I all so have this problems with focbox… i just increase the test Amp and Rpm`s… and then it detects fine…

This worked for me thanks!

1 Like