Motor detection fails - *measure flux linkage* - Conclusion phase wire shorrted

So I have this problem with my motor. At the beginning it was making a weird noise when I powered the motor, I solved this by re-doing the motor detection. Now something had happened during a test ride and 1 of the 3 motor cables got loose.

When I try to do motor detection to let it flow fluently again, I can’t because ‘Measure flux linkage’ doesn’t work. The motor tries to spin and fails miserably, or does spin but with that terrible noise, and still gives off a ‘failure’. I’m using VESC-tool

What have I tried:

  • re-uploaded firmware
  • re-booted the system
  • changing the variables (amps and the other I forgot), which was said could help in the ‘help’ tab of the program. Before all of this happened I didn’t even have to change those it already worked solid.
  • replugged wires

I’ve checked out multiple topics but I can’t come to an conclusion. I never extended my motor cables so a bad solder couldn’t be it and basically (I think) nothing happened in the past days what could have caused this problem.

2 Likes

The flux capacitor has gone bad. You need to source a new unit and re-install.

https://www.oreillyauto.com/

Use this link and tap 121G into the search engine

2 Likes

Could you point me in the right direction? What is that where can I find it.

I’m by no means advanced with technical stuff, idk maybe it’s above my skill level

It’s not even 1 April yet :joy:

3 Likes

I’m sorry but it just seemed too good an opportunity to miss. :sunglasses:

1 Like

First thing to try is physical. Take the belt off and spin it by hand. Does it have a lot of resistance? If it does then do not under any circumstances do another detect. If it spins freely and as it used to then you could try to up the duty cycle and re detect.

2 Likes

I don’t think it has more resistance than usual

1 Like

first spin it by hand and than take the bell off. if you take the bell off you can´t spinn it by hand :stuck_out_tongue_winking_eye:

2 Likes

What do you mean by the duty cycle? Where can I find it

Stop it andy we’ve had enough fun with this fella. The belt. The belt off. Not the bloody bell. :joy:

You got a screen shot of the duty cycle window for him? Its just below the detect button.

1 Like

first the dual cable from @Wraith and than the “belt”… I really was reading bell… sorry for that… :joy:

But @Superflim which motor is it? can you hear that strange sound also when turning with hand? you sure no any of the phase wires touch each other with blanc parts? you doing motor detection without belt on, right? because that can be a reason too. did you try motor detection in bldc too or only foc?

3 Likes

Alien power systems 6374 200kv

No strange sounds when turning with hand

No nothing touching but there is a bit of wire exposed where the heat shrink got off. I’ll put some new on.

Yes I do without belt.

Have tried bldc and foc both

Get the detect page up and look just below the little detect arrow. There is a window with duty cycle there. Up it it small increments until the vesc detects the motor. When a motor fails detection it will cog and make a brrrrrrrr noise.

You mean this? 555fcf77c706894681fc829237a77f08

Go to the motor detect page and screen shot it

eb32f7b0c12286e2ded64bd6c46bfc6a

@Andy87 Mate can you help this guy?
@Superflim I use bldc tbh. Apologies for the wasted time but I’m sure andy will sort you out. foc is like a different language to me.

2 Likes

I never needed to change any parameters to get my motor detection successfull done. @Superflim if you have a multimeter you could measure the resistance between tha phase wires. A to b, a to c and b to c. They all should have the same resistance

Yeah I’m gonna put those cables on the side for now lol

Check for faults. I had this exact problem, and supposedly there was a drv fault.