Nano-X Remote Issues

Just wondering if any of you are having issues with the new Nano-X remote from Enertion? It’s a great remote when compared to the “Winning” that I received with my Raptor 1. But it’s only good one time. What I mean by that is that it binds once and then after you power the board down it doesn’t pair again until unplugged from the receiver and then plugged back in. I have 2 Nano-X’s and they both do the same thing. Let me know if you guys with the same remote are experiencing the same issue.

1 Like

I’m having the same problem. I’ve gotten it to bind 2 times. both times it failed to stay synced after restarting the board. I’m currently talking with customer support to get this fixed, but no updates yet.

1 Like

Guys, when you turn your board off, turn the remote off also.

Then turn the remote on, after the turn the board on.

The nanoX goes through it auto bind process averytime it shuts off.

The auto bind can be instant or take up to a min… i know thats annoying, when you just want to leave


The auto bind should only be happening one time. Once it’s bound to the receiver it should turn on instantly. I am turning on the board and remote in the correct order. I’ve let the remote sit attempting to bind for over an hour before… still nothing.

The receiver will go through the auto bind everytime it’s powered off.

Turn both off, wait a good 10 secs for the bulk caps to discharge

Turn remote on

Turn board on

Wait for bind

I’ve tried that and in many combinations. None of which worked. Kind of a bummer because I love the size of this remote. The only remote that’s been reliable so far has been the gt2b remote mod (Mad Munkey) from @FLATLINEcustoms.

If you guys decide you want a new remote you should check out the Benchwheel from MEB, it’s awesome. I have 3 of them, never had an issue with any of them.

You can also get it a little cheaper, but takes forever to shop from Alibaba. Check out me thread on remotes.

1 Like

I also have 2 of them, 1 in my trampa, other waiting for summer.

The most i waited was a little over a min

I’m happy with my gt2b mad munkey remote. I just thought I’d give the nano-x a try. Sad that it doesn’t work as expected.

Just give what i suggested a shot, you already have your plan B (or A)

1 Like

Atleast your controller works, mine doesnt even powe on! The receiver doesnt power on but the transmitter does. Its literally impossible for me to even use it! I thought they wont have any issues due to the fact that they delayed the shipment of the controller by like a month.

I thought it was my servo wire that is the problem so i bought i new one and cut the old one off my esc and soldered a new one. It still didnt power on. I plugged my newly replaced servo wire to my esc led card programmer to see if the wire works and it did. So im 100% sure that the receiver is faulty.

Here’s some pictures

I have somewhat of the same problem here also. But i’m beginning to think it is the temperature. If my board has been stored cold (-10C) than the remote will not connect anymore to the receiver after turning the board and the controller off for a break. I’m trying to store it warm now and see what happens. If anybody has any other suggestions, more than welcome! @Blasto This should work indeed but after this procedure it should connect almost instantly.

Ok guys, I’ve located the problem. It seems indeed to be the cold. After putting my board in a nice and warm room for half an hour, the controller connected almost instantly with the receiver… I’ve send this information also to Enertion so I hope to get a descent reply from them.

1 Like

I’ve got it to bind every single time for the last couple days now if I don’t hold the remote fully in my hand. I turn on the board, then turn the remote on while dangling it by the lanyard and it binds every time now.

And what is the temperature at your place? Here where I live it is quite cold now (-5C). If I try to let it bind outside then it will not bind, even if I lie the remote on top of the board for half an hour, no matter which order I use (first the board on or the remote). When I put it inside again for some time it will bind almost instantly… No reaction from Enertion yet, if they reply with a solution I will post it here too.

1 Like

It’s pretty cold here. Today has been one of our warmer days so far. I leave my board in the freezing cold garage for the most part.

Alright, and it still connects? That is strange, at least mine wont do that. You could try it after having it in the living room or so for half an hour and see if it connects faster then. If so then this is proof for Enertion that they have a major bug in their product.

1 Like

Well most of the customer electronic, are not made to stay in the cold… (specially if they are made for a summer hobby :confused:)