Need help with Nano-X tx/rx

Alright, I received all the parts I needed for my first build. Now what pissed me off a bit at first was not to receive a bind key with my receiver (Nano-X), but I figured I could just connect two of the pins together to get the same result. I tried to find on the internet how to bind the nano-x transmitter to the receiver, and in every video there is a red blinking light on the receiver, which I don’t have. There is no red blinking light and the transmitter won’t bind.

Do you have any picture of your connection, so we can help you double check them… alao the nano-x have a auto-bind fonction wich do not require a binding tool.

note : VESC lights are on while the receiver’s light isn’t

Have you try to just plug one vesc at the time… just to see if the problem is from the connection or the receiver

Light doesn’t turn on on the reveiver, tried with both or only one VESC at a time. No change, no red light.

Your cable are inverted inside your connector… it should be brown, red, yellow (same order as on the vesc)

Edit: can you double check (still not 100% sure, since I’m on mobile :slightly_smiling_face:)

Doesn’t light up on both sides anyways. Tried brown, red, yellow and yellow, red, brown. No red light on both sides… :confused:

Do you have an Arduino? You can make a simple script to power the receiver, and also listen for the 1-2 millisecond pulses. Or, use any 5v power source, and a small hobby servo to test it.

I don’t have an Arduino, no idea what it is either

You can use a servo, also. I was just going to recommend a micro controller because some people don’t have servos.

I don’t have that lol

No… the cable inside the connector… they had swap some cable when soldering them on the vesc… brow (gnd), should be on the outside side of the receiver, red(5v) should be in the middle and yellow (signal) sould be on the interior side of the receiver, same order on the vesc…

But if you look at your the red and brown are not in the same order on your vesc and on the connector.

I start thinking the receiver is just dead… First build big problems lol

Not sure I’m following you here

I wonder if the Nano-X has a light regardless of connection? Maybe you need to rebind the controller and receiver.

Edit: JohnnyMeduse may be right. Just make sure the ORDER matches on both ends, and then turn the cable around to get it to work.

Just checked, I think the camera took the wrong color. Red is in the middle, orange to the right and brown to the left, same on VESC

Then it should work- if not, flip the connector on the receiver side. It’s good form to make sure that it’s right-way-round, but if you need to you can use it backwards if you’ve already soldered one end.

As I said, doesn’t work on either sides… Tried flipping and flipping, nothing works. No red light receiver looks dead

Oh. What about trying the other ports on the receiver? Is it in the wrong one?