Problems setting speed for meepo hub motors using flipsky dual fsesc 4-12-100a vibrating/erratic motor

Is this on the bench, or when riding?

What remote you have?

Can you make a quick video, load it to YouTube, then post link here. thanks

It is on the bench. I’m using the VX1 remote. I purchased the remote and vesc from Flipsky. I thought they would be compatible.

here is a video of the problem

Here is what it looks like in vesc tool.

IMG_20200416_102014|375x500 !

Ok, I noticed somthing new. If only one motor is hooked up, this doesn’t happen.

Hey bro, did you find the solution for your problem? I am having the same kind of vibration and also getting hot. My setup is really similar to yours, so maybe you could help me out.

Looks like ERPM not set, ERPM much lower I believe for hubs, since less kv, so set your ERPM limits as vesc defaults to much higher. Try starting with low 20k ERPM and slowly move up and find maximum where it doesn’t drive the motors too hard. Also you can calculate your battery voltage × kV × 7 to get the max ERPM.

No, I even bought new hub motors. I was going to just buy a new (different)vesc.

You erpm is too high 23 volts x 70kv x 7 = 11270 we

I can see your vesc app showing it stalling at just around 13k.

Set erpm to 10k first and it should get rid of the problem.

You are basically trying to run hub motor at faster speeds than it can handle.

I just used 70kv as an average of hub motors but use your own motor kv specs should be around 70 to 90kv tho.

1 Like

I will try that. I’m not sure what the KV on meepo 90mm or 100mm motors is.

1 Like

Actually now it doesn’t even detect the hall sensors.

Where does the 7 come from? volts * KV * 7?

Try reflashing firmware.

7 poles, see

Is that the actual number of poles divided by two? I was under the impression that poles were opposing electro magnets so there would always be an even number.

Never mind, I see: Example: 7 Pole Pairs in motor, ERPM limit set to 70000 >>> RPM = 70000 / 7 = 10000 RPM.

1 Like

Did you get it working? I built a quick duct tape board to test out sensorless hub motots.

I’m actually tired of messing with this thing. Some times it sees both motors. Sometimes it sees only one. Some times it tells me the firmware is up to date. Sometimes it says it’s not up to date. I update it, then it seems like it’s ok. Then, it tells me I have to do it again. On my new motors, it’s not detecting the hall sensors. I even went through a back and forth with FlipSky tech support and it’s still not working. I’ve used different usb cables and tried both of the usb ports on the vesc. I’ve used the bluetooth module to program it through the phone. I was considering buying a different vesc. looked @ these,searchweb201602_,searchweb201603_ I also found some guy on facebook (enertionUSA) who is selling the same thing. His store is down because he’s moving.

Ohhh I think I know what the problem are you running FOC mode? Also you need to move around the wires on the hall-sensor to match the vesc pin out.

Check what it says on the flipsky haven’t use that kind yet. Also what voltage?

Did you guys ever get it working, I’m running flipsky 4.2 plus with meepo hubs without issue. 36mph top speed