(RESOLVED) VESC Help On NYE - Failed Motor Detection

Hey everyone! To start off, if you’re reading this thank you! I’ve outlined below my Failed Motor Detection scenerio and as much info as possible. If you could help that would be such a blessing! I’ve really taken my time putting everything together, little by little. I finally worked up the courage to plug in my 10s2p 5000 mah Lipo to a series connector to a 9mm bullet/XT90 adapter to my vesc () to my 6372 motor (enertion).

I was able to connect and flash my VESC and make sure I had the 2.18 firmware as recommended. When I went to hit the detect motor button, I was like a little kid waiting for Santa, until nothing. The motor moved like a centimeter and I was given a message that I had a Failed Motor Detection.

Here is a pic of my read configuration:

Steps taken after motor detection failed: • Flashed VESC and installed firmware path C:/Program Files (x86)/BLDC Tool/Drivers/firmwares/hw_410_411_412/VESC_default.bin • Adjusted current and min erpm • Decreased low duty down 0.1 • Lipo capacity was only 25% first try of motor detection. Charge Lipos to 100% or 42 volts • Tired detecting on both PC and Mac • Tried several length mini usb wires

I tried these steps individually and in combination and still the same results. I’ve also added a picture below of my VESC in case you all can see something in the VESC I cannot. If you need me to take off the shrink warp let me know and I’ll take new pics. Anyhow, I know it’s NYE and most likely I wont’ get many responses but, I’d like you all to know their are some bright minds in here and honestly, building is our fun. But, trust me I’d probably be out if my kid wasn’t sick, LOL. In any case, happy new year everyone!

could you in the terminal and write down “fault” after you retry a motor detection to see witch was the problem exactly ?

EDIT: faults I forget the s


Awesome! You’re the first and only to reply :smile: Could you elaborate on what you’re saying? I’m not sure what you mean: [quote=“JohnnyMeduse, post:2, topic:15414”] could you in the terminal and write down “fault” after you retry a motor detection to see witch was the problem exactly ? [/quote]

of if it’s easier than explaining a screen shot of what you’re trying to say would be so helpful. Thanks man! You’ve definitly made it feel like I’m not stranded alone haha :sweat_smile:

Oh your not alone! It just takes some of us a while to see the threads :wink: Connect your VESC to your PC and connect to it. From there go to the terminal tab in the BLDC tool. Enter in fault on the bottom, tell us if anything comes in.

1 Like

In the BLDC tool, go to the terminal tab and type fault in command line field. You should get a result, post that here and I’m sure someone will help.


You can also go to the “real time data” tab, and click “active sampling” which is located at the bottom. It will show the faults in the bottom left.

1 Like

Awesome! Thanks @Alextech @mmaner @cmatson & @JohnnyMeduse let me give your suggestions a try. But, it will have to be in a bit as the wife is calling, LOL! However, I appreciate your quick response.

1 Like

@JohnnyMeduse @Alextech @mmaner Thanks again guys! After typing in fault in the terminal tab, like you all had mentioned, I come up with the response FAULT_CODE_NONE (image below). Also, @cmatson after following your method of clicking the realtime data tab and activate sampling box the fault code shows NONE (image below). I hope this makes sense to you all as this is now going over my head at this point. Let me know if I can help narrow down the issue any more for you.

@JohnnyMeduse @Alextech @cmatson @mmaner hey guys happy new year! Anyhow, uploaded my fault results as you all suggested. Any ideas you can share?

Well no fault codes! That’s a good start. Those wavelength on the graph show that it is trying to send current to the motor. Are the all the phase wires connected?

1 Like

Is the remote application disabled. It looks like you have no remote connected at the moment but please set it to disabled and then try the motor detection again. Just to be sure.

1 Like

Did you change the bullet connector for the motor lead ? If so can you remove the tape and take a picture, of your soldering.

Also be sure to do a read before trying the motor detection.

Thanks! Glad to hear that’s a good sign. Yes, the phase wires are connected.

Thanks for helping! You’re right I do not have a remote attached as of yet. When you refer to the remote application are you talking about the App Configuration tab and the PPM tab? It does say disabled and under the General tab it say No App.

Hey Johnny thanks for the reply! I did change the power leads from the Lipo. The leads on the motor have not been changes since receiving it. Are you suggesting I take of the shrink wrap from the motor leads to show you?

Try to reflash your Vesc. Then afterwards, Put your Battery details, Then try the motor detection agian.

1 Like

Reflashed VESC with 2.18 firmware. Next read configuration. Start detection…same results.

Because the VESC is connecting and when I click activate sampling there shows a graph. Does that lead you all to believe that the VESC is in working condition?

does the red led flash when you try to run a motor detection ?

1 Like

It does! When the power supply is attached the blue and green lights are lit. When connected to the VESC and any action is made on the keyboard or trying motor detect the red light will blink. Hope that helps.