Sensored motors cogging and jittering - WHAT'S WRONG?

That’s true, I confirm that 100%, it is so powerful that I think this beast could kill me one day :joy: But at startup it’s a tweeting bird right now.

I’ll check it again with short cables, I just need to stop writing, lol…

Yes noticed the wrong settings, one was 40 and one was 50. they are now back to the origonal settings.

Frank the Sensor cables on mine are not extended. I am going to try the 13 tooth pully this weekend, Ted sent me some over with my Vesc 6’s which i hope to have in next week. I will be talking with Sanjoy to match his settings on the Vescs.

@sanjoy s board runs like a treat.


.04 is the default value btw not .004

you’re right, my bad.

I would be willing to bet your problem is in your wire lengths. You have tried just about everything else.

Wondering if it’s to do with belt tension. I could see a scenario with startup problems if the belts are too tight. Most pulleys aren’t totally round either, so it’s possible the belt feels good in one spot but too tight in another. Is there the chance to reduce belt tension just a smidgen?

1 Like

my EMTB having slightly cogging while start up on concrete, and more serious on grass. using sensor hybrid mode. i try take some video to show.

The torque this setup should produce would eliminate it being belt tension or slightly out of round pulleys.

@trampa @esk8 @flywithgriff @Jinra I tried it again with 30 cm / 12 inch phase wires and 15 cm / 6 inch hall sensor extension with one motor. I’m waiting for someone yelling “hidden camera”, I think these wires can’t be too long. I’m frustrated now, leaving the country for 3 days and get a fresh mind but I really don’t know what to do.

Yea, I didn’t think it was the wire length. Honestly pretty sure it’s just a mixture of load and the inaccuracy of hall sensors in general. You’d probably get less cogging with both VESCs setup, and a bit more aggressive of a start on throttle.

At least from the video, it’s about what I’d expect in a 120 degree hall setup on AT single.

@Jinra The cogging with dual is just the same. The motor has a lot of torque and i can start like a rocket if someone give me a push from behind :joy: I only had sensorless motors before and the difference is nice but not on startup. I wonder why people with VESC 6 and these motors have buttersmooth startups, it’s the same 120 degree hall sensor??? Like it is I can’t go offroad (or never stop).Everytime I have to push it like a longboard but with one foot strapped, I could brake a leg while pushing, I felt down several times and hurt my legs. Try to push a mountainboard in offroad conditions strapped. It feels more scary than riding :wink:

But i saw @laurnts is using HW4.12 with 118kv trampa motors, but I think with FOC. So laurnts, how is your startup performance and did you test it in BLDC mode? Would be very interesting.

i don’t doubt the torque of the motor, but load can still be an issue for the motor to startup. As an anecdote, I’ve noticed more stuttering on my larger 63mm motors (sensored) than on my 50mm (sensored).

How is belt tension, not too tight correct?

it’s quite loose, never had belt slipping. But cogging is the same with more tension, makes no difference.

You mentioned you tried 4 different vesc’s but are they different brands? Which brands did you try? I have the same issue on a street board with maytech’s.

Edit, if your wondering I’m using Ackmaniac’s firmware. I installed a bootloader. So the firmware does not fix the issue.

1 Like

Well, meanwhile I’ve tried six V4.12 :joy:. The first two are FLIER, ordered from scramboards with broken temp sensors and hall sensor ports. But first i didn’t recognize that the hall sensor table detection failed. No 3 and 4 are MAYTECH, one of them had broken hall sensor port, too, @JohnnyMeduse found the cold solder joint on one pin in the picture I’ve posted in a different thread. After resoldering it worked but the maytech 4.12 have strange behaviour and are poor quality, I’ve tried 3 different FW and everytime other/new problems (2.18 was best). Both maytech FW 2.18 had max current ramp step bug. No 5 + 6 are from, good quality and performance but all 6 V4.12 have same cogging no matter if sensored, hybrid or sensorless, the cogging is always the same as in sensorless mode.

Got a reply from Benjamin Vedder in the Vesc-Project forum. He says that startup performance is better with FOC and should work with low kv motors like trampa. So next week I’ll give FOC a try (but with the maytech first), if I fry them I don’t really care anymore… I’ll let you know!

Ok good to know its not a brand specific issue.

Edit; I am running 140kv so I guess its related to very low kv motors?

I spoke to maytech directly and they said not to run foc, but some users had success, I think it depends on the motor and settings if it survives.

Did you try the hip wiggle move to get the board moving without putting a foot down?

Funny that in the manual of maytech 4.12 FOC is a own chapter :joy: But I read in this forum there are wrong and missing parts on the maytech pcb’s that’s why people fry them. Normally I would not try FOC on maytech but I’ll try it next week with FW 3.26 and FOC for science! But to be honest, I think they gonna die…[quote=“lrdesigns, post:58, topic:29245”] Did you try the hip wiggle move to get the board moving without putting a foot down? [/quote]

Yes, that’s my move on grass when it’s flat :laughing:

I skimmed through the thread.

How do you configure each vesc? Via CAN fwding or via usb one at a time?

If you use CAN fwding, you will overwrite the hall table of the slave and not have the proper hall table on your slave. So the slave will gogg and with tracking control it will prevent the master from turning. Once you hit a certain erpm, the sensors are ignored.

Edit: nvm, don’t think this is the issue, just saw the last video