Sensored motors cogging and jittering - WHAT'S WRONG?

I configured each vesc standalone with their usb, afterwards connected CAN.

:grin::laughing::smile::joy::sunglasses:! IT’S WORKING LIKE A CHARM NOW! Thanks for input @trampa @esk8 @Jinra @Namasaki @flywithgriff @Blasto @Titoxd10001 @Irdesigns Silverline, Sander, JLabs, Petertaylor, lox897!

As benjamin vedder said, the solution is so simple: FOC!!! I use FW3.26 in sensored FOC mode and my sleeping lion is awake! Roooooarr! The difference in start up performance is not like day and night, it’s a complete different universe compared to sensored/hybrid mode in BLDC.! I am so happy after the last disappointing weeks, I can’t stop smiling when i push the throttle :heart_eyes: and I can’t hear the motors anymore, wicked! It’s still a beast with motor max / batt max. 40A, lol., can’t wait to test it outside soon!

@Irdesigns @marcuscrackus @benwong, sensored motors like FOC, not BLDC! I’ve tried first FOC with my maytech 4.12’s, everytime I brake there is a DRV fault and cut off on both V4.12’s no matter which settings. So i put my 4.12’s on FOC and didn’t have any faults or cut offs so far, they seem to like FOC like me :grin:

As evidence I’ll post a video here within the next days so you can see the awesome startup performance of my new trampa lion!!! What is cogging? never heard about :joy::joy::laughing:


Awesome man! Glad it’s working for you now! Def post a video.

1 Like

Congratulations! You are now a FOCer!


1 Like

I would say I’m a motherFOCer frank :joy: I can’t resist to test it now outside, it’s night but I have bright offroad lights and don’t wake my neighbours with FOC :laughing:

Happy FOCing in the dark! Don’t kill yourself.


1 Like

Good to hear you man.
I try FOC once in benchtest. It is quiet. But i switch back to BLDC, just worry will fried my VESC. I am happy with BLDC so far. But maybe future will try FOC.

I yet free to take some video showing the cogging. Let me do it today~~

I could FOC all day and night, It was FOCing great!

I’m back from my 12km nightFOC and can’t stop to grin. I’ve tested startup from standstill on different terrains, grass, crushed rock, mother earth and everything else I’ve found on my way. Everytime butter smooth startup from zero to hero! Starting uphill from standstill no problem at all! Even when I rolled backwards on a hill I could start forward… I’ll be back and FOC around a lot!

2 days ago I thought I will never ever use my heelstraps because it’s too dangerous. But now I can’t wait to mount my FOCstraps! :stuck_out_tongue_winking_eye: When I reached home I connected my V4.12’s to VESC-TOOL and checked for faults in terminal, I was scared but “No faults registered since startup” :grin:


The new VESC-Tool is FOCing amazing, isn’t it. Once public, there will be a lot more FOCers on this planet. You should feel how FOCing amazing the new VESC FW is in combination VESC SIX. The old 4.12HW can’t make use of new FW features. They run better then ever, but not as good as the new HW designs.


1 Like

Here the promised video, wanted to make a short one, now it’s almost 15 minutes :joy: comparing FOC and BLDC mode. But don’t worry, the startup performance part is in the beginning :wink:


Awesome video man!! Can’t wait to have mine up and running foc.


Finally got my setup rolling. But guess what, COGGING! And im already running FOC.

Oh no! Cogging at start up only or during riding as well? You have FOCBOX, isn’t it? Just to get sure, you have sensored motors and chose “sensored” FOC, right? Did you extend your sensor wires with JST connectors?

Just on startup and you are correct on the FOCBOX’s. My motor max is currently at 40 so I’m assuming I may have to bring it up to 60 or so.

Have you tried setting the min eRPM higher? Min erpm is like min throttle on quads. When min throttle is to low sometimes the motors cog because the back emf is to low. For example

Stock is min erpm150. I have mine set to 307. This allows my motors to start without cogging in both bldc and foc.


I wasn’t aware this was even a thing to be adjusted. I will look into it for sure.


I am afraid that won’t change anything :disappointed:

Do you use sensor wire extensions (with connector) or is it directly plugged to FOCBOX?

I upped the motor min to -60 and max to 60. No more problems. My sensor wires run directly from motor to FOCBOX connector.

1 Like

I am glad that it works for you now :grinning: didn’t expect that increasing motor max solved it.

I think maybe motor min helped me out.