Slave motor starts turning then stops

So my master vesc is running fine, by when I accelerate my slave vesc will accelerate for a second then stop all together until I give it 0 throttle and start again. I’ve tried changing the polls over and ran motor detection on it, when its doing the detection the motor spins exactly as it should. Any ideads? Thanks in advance

are they connected over can?

Yes 10 char

Does the cable wiggle? Does the motor spin after you set up slave/master and use the computer to spin the master?

Cable is in fully and doesn’t move. it was working fine but I left my board alone for a week or 2 and this happened. Yes, when I run motor detection the motor spins as it should

no arrow controls not detection

When I give it some throttle the esc lights up as to say its receiving the signal okay

I’ll try that now

When I use the arrow keys on BOTH of them they just judder back and forth. Forgot to mention im running it in FOC if that matters

That is weird

do you use vesc-tool or bldc tool?

VESC tool 10 char

Reflash them and re configure.

When you say that do you mean use the wizard again? I’ve tried that and nothing

Firmware update

hes on the latest FW already.

try downgrading to 2.18 and use BLDC tool

1 Like

Yeah I just tried reflashing anyway, I’ll give this a go now

1 Like

BLDC tool makes you realise how easy the VESC tool is lol I’m just confused as this was working a week or 2 ago


are you using sensors?

Yes 10 char