Stutter when taking off

Hey guys, I’m having trouble with my setup. I have a Focbox Unity with Wowgo AT hub motors. Everything works great when I’m moving but starting off the motors stutter so I have to kinda kick start.

Is this something I can fix in the Unity app on my Android? I ran the setup for the motors and I’m running them sensored. I’m running everything at 60 amps output since that’s what my battery pack is.

What kv? And what gearing

If you have sensors and it’s still stuttering, then it’s likely a configuration issue. Are you sure it’s running in sensored mode, and did you do the proper motor setup?

I don’t know the KV as Wowgo doesn’t publish that info. No gearing as the Wowgo AT motors are hub motors. And yes, as I said in OP I ran the setup and I’m running in sensored mode.

what are your sensor readings

Not sure how to read them on the Unity? Is that something I do on the Terminal screen?

have you set them up in sensored FOC mode?

As I put in my original post, yes I did.

yes but are you using FOC

1 Like

Can’t find any info there. I bet you run sensored BLDC mode that’s why the motors are stuttering. You have to set them up in sensored FOC.

How big are you wings and at which speed you can take off? :wink:

1 Like

Where can I confirm this setting in the app?

Actually you didn’t. There’s is a very distinct difference between sensored and FOC. You might be a little more receptive to advice and do some research so you know what questions you ask.


If you’re using the app take a pic of your motor screen so we can see Hall positioning

1 Like


Interestingly enough, I re-run setup and a small status bar at the bottom says “Both Motors Sensorless” for a split second. Perhaps the wires aren’t in the right place? I thought it was able to auto detect the various sensor wires too?

You need to change the sensorless erpm value in the full tool.

Are you on the latest firmware? 23.43

When you say “full tool” do you mean the Windows app? Ugh, making my life so complicated with my Mac and iPhone! Haha. I’ll run a Windows VM and pray I can talk to the device. The firmware is the latest it said to upgrade to via the app, not sure the version #.

Check the firmware tab to see which one you’re on. We released a new fw a week or so ago

Those hall values are missing. Also your motor inductance values are widely different for some reason.

Yes, it’s currently 23.43