Tester needed for VescUartControl with new Interface


The Interface on the Vesc changed with the new firmware. I already adapted the necessary changes and merged also some change requests. But: I have currently no VESC to test this stuff. So I was wondering if somebody is out there using the VescUartControl and wants to test the changes for the community so I can merge the stuff in the master and bring out a new release. The changed interface was already tested and also the pull requests. But not all stuff together.

You can find the newest version in this branch: https://github.com/RollingGecko/VescUartControl/commits/VESC6 I opened also an issue for this help request:https://github.com/RollingGecko/VescUartControl/issues/15

Would be great if you could participate.



Just to get this clear, would it also help to test it with 4.12 Hardware and new Firmware? I think i should be able to test it tomorrow, but it will be while until i get some VESC 6’s.

It is only about the new firmware. So 4.12 would be fine!

I have 4.12 hardware runing and latest firmware from the latest VESC tool.

I’m your man! (no gay comment implied)

Alright i will do some testing as soon as i get the chance (still away from home…) Can’t wait to use the library again for my next remote and board!

Waiting for your test results guys!

I’m guinea pig I’ll do it too! … when I successfully reinstall my arduino on computer ! Damn installation is gruesome !

I gave it a try today but i can neither get my esk8.de vesc or 1.1 controller (both running 3.28fw) to work with the new code. Old version still works for controlling the motor besides theres no telemetry.

True,true. ArduBoardControl was not yet adapted to the changes in the library. Added now SetSerialPort also to ArduBoardControl. Now it should work…I hope.

Please give it another try. You will find the changes in this branch: https://github.com/RollingGecko/ArduBoardControler/tree/V6



Thanks. ill give it a try tomorrow. But im not sure this will change anything as im just using your library and created my own rx&tx code. I did already add the changes from your initional post to my library. Maybe I messed up when I merged the codes together as i had to remove the multiple serial ports part (using an arduino nano)

Guys it makes no sense to test a library that you changed. The test is not representative at all.

The code is backwards compatible. The functions are overloaded. Once without setting the serial port to use and once without. Like before. The only thing you have to add is a SetSerialPort(&Serial) to your code in the setup part. Then normal a Serial.begin(xxx). Same with SetDebugSerialPort if required.

1 Like

ok maybe i wasnt clear enough. i updated the library based on your instructions at first place but didnt manage to establish a connection to the vesc at all. then i tried to make it work but no success so far.

i FINALLY had the chance to test it! and look at that:

It works!

Tested with 4.12HW 3.34 FW VESC

Thanks @RollingGecko, you make my projects possible! :heart_eyes:

(btw does it matter that i didn’t try sending stuff to the vesc? didn’t have a spare motor to connect to it)

Nice work! Still doesnt work for me :confused: old version with 2.28 firmware is just fine but with the updated version I can get my Arduino to the VESC Can you try to connect a Nano? Cause there are 2 Options right now: Code doesnt work with Nano or i messed sth up(more likley :joy:)

Have tried only with mega, might find time to test with nano tomorrow. My uart settings were standard 115200 baud. But next time I want to use nanos for my project, oh well.

Alright i gave it a quick try with the Nano. My Method was reading the data via the example sketch and storing the input voltage in EEPROM. Then i read the EEPROM using another Sketch. Unfortunately the Number in the EEPROM stayed 0.00. However, this isn’t the best way to check this and i can’t say that it’s impossible that i made a mistake as i did this in a hurry, so it would be great if you could try to test this with something like softwareserial.

Tanks. Im sending the data to my remote and display it on an oled screen. Same problem, every number stays zero. Another weird thing is that it appears that my nano “stops” when it tries to communicate with the VESC. I will “borrow” an arduino that supports multiple serial ports from school tomorrow and give it another try.

Any updates on the nano? My next remote project really depends on this so i might need to track down a small mega as an alternative.

Unfortunately theres no mega or similar in my school. but will get one from a friend by monday. so next week i should be able to try it next week

We know that it works on the mega, it would be more interesting to see if you could get it working with the Nano :smile: